Bug 199067 - Autoconf 2.60 seems to break apr and apr-utils
Autoconf 2.60 seems to break apr and apr-utils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apr (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-16 17:45 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2.7-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 08:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-07-16 17:45:43 EDT
Description of problem:
Autoconf 2.60 seems to break apr and apr-utils, below are some lines from my 
rebuilding:

[...]
libtool: install: warning: remember to run `libtool --finish /usr/local/apr/lib'
/usr/bin/install -c -m 644 apr.exp /var/tmp/apr-1.2.7-9.1-buildroot/usr/local/
apr/lib/apr.exp
/usr/bin/install -c -m 644 apr.pc /var/tmp/apr-1.2.7-9.1-buildroot/usr/local/
apr/lib/pkgconfig/apr-1.pc
for f in libtool shlibtool; do \
            if test -f ${f}; then /usr/bin/install -c -m 755 ${f} /var/tmp/apr-
1.2.7-9.1-buildroot/usr/lib/apr-1/build; fi; \
        done
/usr/bin/install -c -m 755 /usr/src/rpm/BUILD/apr-1.2.7/build/mkdir.sh /var/tmp/
apr-1.2.7-9.1-buildroot/usr/lib/apr-1/build
for f in make_exports.awk make_var_export.awk; do \
            /usr/bin/install -c -m 644 /usr/src/rpm/BUILD/apr-1.2.7/build/${f} /
var/tmp/apr-1.2.7-9.1-buildroot/usr/lib/apr-1/build; \
        done
/usr/bin/install -c -m 644 build/apr_rules.out /var/tmp/apr-1.2.7-9.1-buildroot/
usr/lib/apr-1/build/apr_rules.mk
/usr/bin/install -c -m 755 apr-config.out /var/tmp/apr-1.2.7-9.1-buildroot/usr/
local/apr/bin/apr-1-config
+ mv docs/dox/html html
+ sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' '/var/tmp/apr-1.2.7-9.1-
buildroot/usr/lib/libapr*.la'
sed: can't read /var/tmp/apr-1.2.7-9.1-buildroot/usr/lib/libapr*.la: No such 
file or directory

Version-Release number of selected component (if applicable):
apr-1.2.7-9.1
autoconf-2.60-3.1

How reproducible:
Everytime when using autoconf 2.60.

Actual results:
Autoconf 2.60 seems to break apr and apr-utils, because it tries to use /usr/
local instead of just /usr - but any parameters and options passed by rpm to the 
macros seem to be correct.

Expected results:
Working rebuild, no use of /usr/local... ;-)
Comment 1 Joe Orton 2006-07-17 05:53:12 EDT
Known issue, the APR configure script has some awful hacks which broke with
autoconf 2.60.
Comment 2 Robert Scheck 2006-07-17 14:33:31 EDT
Okay, hopefully this issue can be fixed soon, because httpd unfortunately has 
the same problem...
Comment 3 Joe Orton 2006-07-19 08:12:45 EDT
The patch in -10 should fix this.

Note You need to log in before you can comment on or make changes to this bug.