Bug 199071 - Need for HTML Editor Tool on Core Disks
Summary: Need for HTML Editor Tool on Core Disks
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-16 23:26 UTC by apf
Modified: 2014-03-17 03:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 21:14:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description apf 2006-07-16 23:26:39 UTC
Description of problem:
Mozilla has been deprecated and will not appear in future Cores. This will 
leave the core install disks without a specific website development tool.  
Formerly, Mozilla's Composer provided this functionality.  I would suggest 
Bluefish be moved from the repositories to the Core disks.

Version-Release number of selected component (if applicable):


How reproducible:
Move Bluefish from "extras" repository onto core installation disks.


Additional info:
Webpage creation is a skill that even low-end users are capable of. It is not 
a niche activity, so Bluefish should be moved to Core disks, especially if 
Mozilla is removed from the installation. Using VI or Emacs is of course, an 
option for website creation but is not the best-solution for low-end users and 
lack the specialist features of Bluefish.

Thanks,

David LS.
Hobart, TAS

Comment 1 Rahul Sundaram 2006-07-20 23:55:35 UTC
Thank you for the report.
 
Mozilla suite will be in the future replaced by Seamonkey which is the same code
base as the suite. Seamonkey is available as part of Fedora Extras along with
Bluefish.

Since several other programs like Yelp and Devhelp using Mozilla suite as their
browser engine, We need to either build all these applications against Firefox
or use XULRunner which is apparently not very mature yet

More information at 

https://www.redhat.com/archives/fedora-maintainers/2006-July/msg00364.html



Comment 2 apf 2006-07-21 06:02:02 UTC
Hello Rahul,

Thanks for the response.  I have looked at Seamonkey. So will it be moved from 
Extras to the core disks?  I think it is worthy of it.

Although lacking in some major features like syntax highlighting, the Composer 
module does show promise.

Thanks,

D. Le Sage
HOBART, TAS

Comment 3 Rahul Sundaram 2006-09-26 23:42:19 UTC

We dont plan to move Seamonkey into Fedora Core as we already have a many
browsers and mail clients and dont want to duplicate components. If composer can
be split out as a package. it might be a good candidate for core or Nvu might be
included. 

Comment 4 Matthias Clasen 2007-04-04 02:51:31 UTC
This looks more like a comps change request. Moving to distribution.

Comment 5 Jon Stanley 2008-05-12 21:08:41 UTC
In a post Core/Extras split world, does this matter?

Comment 6 Bill Nottingham 2008-05-12 21:14:14 UTC
Well, other than what may be in kdenetwork, we don't ship a specific HTML
editor; that being said, website development is probably left to a separate spin
that has TurboGears, RubyOnRails, PHP, and so on.


Note You need to log in before you can comment on or make changes to this bug.