Bug 199079 - Trying to view License from Help menu locks up game.
Trying to view License from Help menu locks up game.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 00:29 EDT by Luke Macken
Modified: 2016-09-19 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 10:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wesnoth.strace (477.62 KB, text/plain)
2006-07-17 12:14 EDT, Luke Macken
no flags Details

  None (edit)
Description Luke Macken 2006-07-17 00:29:02 EDT
During a game, clicking Menu->Help->License seems to freeze the game.  I've been
able to reproduce this on my rawhide laptop, and FC5 desktop.
Comment 1 Michael Schwendt 2006-07-17 05:59:01 EDT
Cannot reproduce with FC5. It takes awhile, then displays the GPL in the
help browser: Menu > Help > License
Comment 2 Luke Macken 2006-07-17 12:13:58 EDT
My initial claim was incorrect.  I am unable to reproduce this on FC5, but this
issue still occurs on my rawhide machine.

Attached is an strace of wesnoth starting right before i click "License".  As
you can see, it flips out and _llseeks the same stuff over and over and over and
over (I trimmed the log down from 2 megs).
Comment 3 Luke Macken 2006-07-17 12:14:44 EDT
Created attachment 132556 [details]
wesnoth.strace

strace of wesnoth while trying to read the License from the help menu.
Comment 4 Michael Schwendt 2006-07-18 05:29:31 EDT
On rawhide, it takes something from 90 to 300 seconds until it displays
the licence text. Where exactly it chokes, remains to be examined.
Comment 5 Michael Schwendt 2006-07-18 10:14:12 EDT
will be fixed in 1.0.2-3.fc6

Note You need to log in before you can comment on or make changes to this bug.