Bug 199175 - 'yumdownloader' gives error about yum's 'errorlog' not existing
'yumdownloader' gives error about yum's 'errorlog' not existing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 206828 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 14:39 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-utils 1.0.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 05:54:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to make yumdownloader work with latest yum api (2.25 KB, text/plain)
2006-09-17 07:05 EDT, Tim Lauridsen
no flags Details

  None (edit)
Description Stewart Adam 2006-07-17 14:39:32 EDT
Description of problem:
When I try to use yumdownloader from yum-utils 0.6-2.fc6 and yum 2.9.3-1, it
gives and error of:

Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 156, in ?
    main()
  File "/usr/bin/yumdownloader", line 71, in main
    my = initYum()
  File "/usr/bin/yumdownloader", line 45, in initYum
    my.errorlog, my.filelog)

Version-Release number of selected component (if applicable):
yum-2.9.3-1
yum-utils-0.6-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Use 'yumdownloader' to download any package
  
Actual results:
It gives the error shown above

Expected results:
yumdownloader should download the RPM

Additional info:
Could it be because of yum's 2.9.x development version?
Comment 1 Stewart Adam 2006-08-21 10:58:26 EDT
Still occuring in:
yum-2.9.4-2
yum-utils-0.6-5.fc6
Comment 2 Jay Cliburn 2006-08-28 15:49:58 EDT
Broken for me too.  Any chance of getting this fixed soon?
Comment 3 Brannon 2006-09-05 18:03:55 EDT
As I understand it, this bug is caused by changes to the yum API, which, last I
heard, was still being modified. Anyone heard if the yum API is stable? I would
consider this bug a blocker on the FC6 release.
Comment 4 Tim Lauridsen 2006-09-17 07:05:21 EDT
Created attachment 136478 [details]
patch to make yumdownloader work with latest yum api
Comment 5 Paul Nasrat 2006-09-18 05:29:07 EDT
*** Bug 206828 has been marked as a duplicate of this bug. ***
Comment 6 Tim Lauridsen 2006-09-29 09:25:37 EDT
fixed in yum-utils CVS, will be availible in next yum-utils release.

Note You need to log in before you can comment on or make changes to this bug.