Bug 199202 - nss_wins: samba causes system failure
nss_wins: samba causes system failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 18:14 EDT by Carl Preddy
Modified: 2014-08-31 19:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 00:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Preddy 2006-07-17 18:14:33 EDT
Description of problem: Many applications (thunderbird, firefox, yum itself)
started to segfault after about July 12 with yum nightly updates running.
Strongly suspect new samba packages as root cause. This problem completely
incapacitates my system and I have had to restore from ghost image in order to
continue.


Version-Release number of selected component (if applicable): FC5 


How reproducible: Absolutely (3x so far)


Steps to Reproduce:
1. yum -y update sometime after July 12
2.
3.
  
Actual results:
yum itself will not restart; reports a segfault. Notice that during boot it
fails to start CIFS, which in turn causes all network filesharing to be lost. 
Firefox and thunderbird won't start; also segfaults. I am ok if I restore from
July 7 and update every standard package released since then except samba.

Expected results: none of the above

Additional info: I took the nonstandard repos (freshmeat, livna) out of the
repos list after the first incident thinking that the flaw could have come from
there.Yesterday (7/16) I ran 'yum list update' after restoring from 7/6 and
noted all the packages; samba was not among them. I restored each one and
checked functionality after - no problem. Overnight the scheduled yum update ran
and, to my surprise, it included samba packages that weren't detected yesterday.
Today I'm dead again, hence my suspicion of samba.
Comment 1 Jean-pierre Cartal 2006-07-19 04:22:22 EDT
I also have the same problem on different machines running FC5, all network
applications are segfaulting when wins is activated in the nsswitch.conf file
for hostname resolution.
My nsswitch.conf file for hosts resolution is usually as follow :
hosts: files dns wins
Removing wins from the list stops the problem.

Here is the log I get when pinging using a netbios machine name :
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0]
lib/fault.c:fault_report(41)
Jul 19 10:23:10 nss_wins[7436]:  
===============================================================
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0]
lib/fault.c:fault_report(42)
Jul 19 10:23:10 nss_wins[7436]:   INTERNAL ERROR: Signal 11 in pid 7436
(3.0.23-1.fc5)
Jul 19 10:23:10 nss_wins[7436]:   Please read the Trouble-Shooting section of
the Samba3-HOWTO
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0]
lib/fault.c:fault_report(44)
Jul 19 10:23:10 nss_wins[7436]:
Jul 19 10:23:10 nss_wins[7436]:   From:
http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0]
lib/fault.c:fault_report(45)
Jul 19 10:23:10 nss_wins[7436]:  
===============================================================
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0] lib/util.c:smb_panic(1614)
Jul 19 10:23:10 nss_wins[7436]:   PANIC (pid 7436): internal error
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0]
lib/util.c:log_stack_trace(1721)
Jul 19 10:23:10 nss_wins[7436]:   BACKTRACE: 20 stack frames:
Jul 19 10:23:10 nss_wins[7436]:    #0 smbd(log_stack_trace+0x2d) [0xe52dad]
Jul 19 10:23:10 nss_wins[7436]:    #1 smbd(smb_panic+0x5d) [0xe52edd]
Jul 19 10:23:10 nss_wins[7436]:    #2 smbd [0xe3ea3a]
Jul 19 10:23:10 nss_wins[7436]:    #3 [0xbffff420]
Jul 19 10:23:10 nss_wins[7436]:    #4 /lib/libnss_wins.so.2(toupper_w+0x19)
[0x6a7f69]
Jul 19 10:23:10 nss_wins[7436]:    #5 /lib/libnss_wins.so.2(strupper_m+0x2b)
[0x6a348b]
Jul 19 10:23:10 nss_wins[7436]:    #6
/lib/libnss_wins.so.2(set_global_myname+0x4d) [0x6b033d]
Jul 19 10:23:10 nss_wins[7436]:    #7 /lib/libnss_wins.so.2(lp_load+0x11bd)
[0x6562bd]
Jul 19 10:23:10 nss_wins[7436]:    #8
/lib/libnss_wins.so.2(_nss_wins_gethostbyname_r+0x37d) [0x64b05d]
Jul 19 10:23:10 nss_wins[7436]:    #9 /lib/libc.so.6(gethostbyname_r+0x132)
[0x3a5a62]
Jul 19 10:23:10 nss_wins[7436]:    #10 /lib/libc.so.6(gethostbyname+0xdf) [0x3a53cf]
Jul 19 10:23:10 nss_wins[7436]:    #11 smbd(sys_gethostbyname+0x1d) [0xe419ed]
Jul 19 10:23:10 nss_wins[7436]:    #12 smbd(name_to_fqdn+0x25) [0xe50a25]
Jul 19 10:23:10 nss_wins[7436]:    #13 smbd [0xc9b5f7]
Jul 19 10:23:10 nss_wins[7436]:    #14 smbd(reply_negprot+0x352) [0xc9a9e2]
Jul 19 10:23:10 nss_wins[7436]:    #15 smbd [0xce6c20]
Jul 19 10:23:10 nss_wins[7436]:    #16 smbd(smbd_process+0x7ab) [0xce7d5b]
Jul 19 10:23:10 nss_wins[7436]:    #17 smbd(main+0xbd0) [0xf021c0]
Jul 19 10:23:10 nss_wins[7436]:    #18 /lib/libc.so.6(__libc_start_main+0xdc)
[0x2dc724]
Jul 19 10:23:10 nss_wins[7436]:    #19 smbd [0xc72551]
Jul 19 10:23:10 nss_wins[7436]: [2006/07/19 10:23:10, 0] lib/fault.c:dump_core(173)
Jul 19 10:23:10 nss_wins[7436]:   dumping core in /var/log/samba/cores/smbd
Jul 19 10:23:10 nss_wins[7436]:
Comment 2 Francis Barber 2006-07-22 03:41:17 EDT
This bug also affects x86_64 systems.
Comment 3 Kazuyuki Maejima 2006-07-25 23:40:48 EDT
I have an FC4/x86_64 box which has the following hosts: line in /etc/nsswitch.conf:
    hosts:      files dns wins

Recently samba* packages were updated from 3.0.14a-2 to 3.0.23-1.fc4
by nightly yum update.  Since then, ping or "net lookup" another host
by NetBIOS name causes segmentation fault.
    $ ping remotehost
    Segmentation fault
    $ net lookup remotehost
    Segmentation fault

It seems this problem was reported to Samba's Bugzilla and fixed in
3.0.23a.
    https://bugzilla.samba.org/show_bug.cgi?id=3937
Comment 4 Fedora Update System 2006-07-26 15:39:13 EDT
samba-3.0.23a-1.fc5.1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Carl Preddy 2006-08-02 21:54:26 EDT
Updating to the "a" fix of samba was successful, with no further segfault
incidents. Recommend this report be closed. Many thanks.

Note You need to log in before you can comment on or make changes to this bug.