Bug 199218 - gvim throws pango warnings
Summary: gvim throws pango warnings
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
: 207979 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-18 02:38 UTC by Josh Boyer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.12.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 23:43:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josh Boyer 2006-07-18 02:38:32 UTC
Description of problem:

When editing files with gvim, Pango-WARNING messages are output in the shell
that spawned gvim.

[jwboyer@vader ubi-utils]$ gvim README 

(gvim:17352): Pango-WARNING **: Error loading GPOS table 4097


Version-Release number of selected component (if applicable):

vim-X11-7.0.035-1.1

How reproducible:

Always

Steps to Reproduce:
1. Open file for editing from shell
2. Scroll file
3.
  
Actual results:

Pango warnings are spit out

Expected results:

No pango warnings

Additional info:

This system has the dejavu-fonts installed.

Comment 1 Josh Boyer 2006-08-18 01:49:32 UTC
So I'm still seeing this problem.  I'm also seeing it on FC5 with dejavu-fonts
installed.

Comment 2 Karsten Hopp 2006-08-18 09:38:54 UTC
This looks more like pango has a problem with dajavu fonts

Comment 3 Josh Boyer 2006-08-18 12:40:43 UTC
(In reply to comment #2)
> This looks more like pango has a problem with dajavu fonts

Could be.  Though gvim is the only application I've come across that spits out
this warning.  Now on my FC5 machine with dejavu installed:

[jwboyer@zod ~]$ rpm -qa | grep dejavu
dejavu-fonts-2.8.0-1.fc5
dejavu-fonts-makedefault-2.8.0-1.fc5
dejavu-fonts-experimental-2.8.0-1.fc5
[jwboyer@zod ~]$ rpm -q vim-X11
vim-X11-7.0.042-0.fc5

I still get:

[jwboyer@zod ~]$ gvim cheat

(gvim:16502): Pango-WARNING **: Error loading GPOS table 4097
[jwboyer@zod ~]$
(gvim:16503): Pango-WARNING **: Error loading GPOS table 4097


Comment 4 Josh Boyer 2006-08-18 13:00:41 UTC
Oh, and:

[jwboyer@zod ~]$ rpm -q pango
pango-1.12.3-1


Comment 5 Josh Boyer 2006-08-20 00:55:04 UTC
I no longer have this problem with rawhide, so it's purely a FC-5 issue now.

Comment 6 Behdad Esfahbod 2006-08-21 16:47:53 UTC
It's a totally harmless warning with DejavVu Sans Mono fonts.  It's fixed in
Pango 1.14.  I've fixed that in pango-1-12 branch upstream already, but have not
made a release.  This can be closed as rawhide for example.

Comment 7 Josh Boyer 2006-08-21 16:59:27 UTC
(In reply to comment #6)
> It's a totally harmless warning with DejavVu Sans Mono fonts.  It's fixed in
> Pango 1.14.  I've fixed that in pango-1-12 branch upstream already, but have not
> made a release.  This can be closed as rawhide for example.

Would it be possible to make a release?  I understand it's harmless, however
it's really really annoying from a user standpoint.

Or if you cannot make a release, could you provide the fix in the FC-5 branch in
CVS so users can compile their own updated RPM?



Comment 8 Behdad Esfahbod 2006-08-21 17:08:33 UTC
I'll make a release one of these days...  Leaving open.

Comment 9 Karsten Hopp 2006-09-26 09:06:16 UTC
*** Bug 207979 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.