This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 199344 - runuser needs a way of specifying which groups to use
runuser needs a way of specifying which groups to use
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 199346
  Show dependency treegraph
 
Reported: 2006-07-18 20:56 EDT by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.97-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 11:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix this bug (4.54 KB, patch)
2006-07-18 20:56 EDT, Russell Coker
no flags Details | Diff

  None (edit)
Description Russell Coker 2006-07-18 20:56:23 EDT
Often it is necessary to run a daemon with a GID (or set of supplemental 
groups) that do not match the defaults specified in the passwd and group files 
for the account.  To deal with this situation runuser needs to support 
specifying the groups on the command-line.

Attached is a patch to provide such support for the version of runuser in 
rawhide.
Comment 1 Russell Coker 2006-07-18 20:56:23 EDT
Created attachment 132633 [details]
patch to fix this bug

Note You need to log in before you can comment on or make changes to this bug.