Bug 199357 - eu-strip does not work on sparc
eu-strip does not work on sparc
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 23:04 EDT by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 18:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2006-07-18 23:04:50 EDT
Description of problem:
debuginfo packages on sparc  dont get built  because eu-strip  doesnt work 
correctly  
build log shows 

eu-strip: while 
writing '/var/tmp/kdelibs-3.5.3-4-buildroot/usr/lib/debug/usr/lib/kde3/kded.so.debug': 
invalid section entry size
extracting debug info 
from /var/tmp/kdelibs-3.5.3-4-buildroot/usr/lib/kde3/kded_kssld.so
Failed to write file: invalid section entry size

Version-Release number of selected component (if applicable):
rpm -q elfutils
elfutils-0.121-1

not 1005 sure whats the best way to debug this.  

How reproducible:
always

Steps to Reproduce:
1.build package on sparc
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Bogusz 2006-08-26 06:49:53 EDT
It can be caused by ".plt" section, which in SPARC ELF32 files have 12-byte
entsize, but after the last entry there is single-instruction (4-byte) NOP
placed, so final section size is count*entsize+4.
elflint and libelf check strictly for sh_size % sh_entsize == 0.
I prepared patch for elflint:
http://cvs.pld-linux.org/SOURCES/elfutils-sparc.patch
and libelf check can be adjusted in similar way.
Comment 2 Dennis Gilmore 2006-10-13 18:49:17 EDT
http://sources.redhat.com/ml/binutils/2006-10/msg00101.html 
applying that patch to binutils and rebuilding elfutils seems to have fixed 
the problem. 

BEFORE
-rw-r--r-- 1 dennis dennis 5.6M Oct 13 16:56 
binutils-2.17.50.0.3-6.sparc.sparc.rpm
-rw-r--r-- 1 dennis dennis  31K Oct 13 16:56 
binutils-debuginfo-2.17.50.0.3-6.sparc.sparc.rpm

AFTER
-rw-r--r-- 1 dennis dennis 3.0M Oct 13 17:28 
binutils-2.17.50.0.3-6.sparc.sparc.rpm
-rw-r--r-- 1 dennis dennis 2.7M Oct 13 17:28 
binutils-debuginfo-2.17.50.0.3-6.sparc.sparc.rpm

I havent tested  that the debuginfo packages work  but they appear to be 
created better 

Note You need to log in before you can comment on or make changes to this bug.