Bug 19940 - mgetty-1.1.22-1.6.x.i386 broken
mgetty-1.1.22-1.6.x.i386 broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-27 16:33 EDT by jouni
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 16:13:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jouni 2000-10-27 16:33:49 EDT
The new mgetty does not answer dial-in (GSM ISDN - /dev/ttyI10) calls:

I get this in my /var/log/messages:

ct 27 23:16:33 celon mgetty[1019]: mgetty: experimental test release 
1.1.22-Aug17: Success
Oct 27 23:16:33 celon mgetty[1019]: check for lockfiles: Success
Oct 27 23:16:33 celon mgetty[1019]: locking the line: No such file or 
directory
Oct 27 23:16:34 celon mgetty[1019]: lowering DTR to reset Modem: No such 
file or directory
Oct 27 23:16:34 celon mgetty[1019]: send: : Invalid argument
Oct 27 23:16:35 celon mgetty[1019]: waiting...: Invalid argument

Once (???) it answered incoming call after cold boot [goodbye uptime]:

Oct 27 23:17:24 celon kernel: isdn_tty: call from xxxxxxx, -> RING on 
ttyI10
Oct 27 23:17:24 celon mgetty[1019]: wfr: waiting for ``RING'': No such 
file or directory
Oct 27 23:17:24 celon mgetty[1019]: send: : Operation not permitted
Oct 27 23:17:24 celon mgetty[1019]: waiting for ``CONNECT'': Operation not 
permitted
Oct 27 23:17:24 celon mgetty[1019]: send: : Operation not permitted
Oct 27 23:17:24 celon mgetty[1019]: waiting for ``_'': Operation not 
permitted
Oct 27 23:17:26 celon mgetty[1019]: data dev=ttyI10, pid=1019, 
caller='xxxxxxx', conn='64000/V110/19200', name='', cmd='/usr/sbin/pppd', 
user='/AutoPPP/'

.... (PPP handshake started)

Downgrading to previous/original version solved the problem.

Best regards,

Jouni
Comment 1 Bruce Garlock 2001-01-23 09:49:24 EST
This bug has been around for a while.  Any idea when it will finally be squashed, Redhat?
Comment 2 Jason Vas Dias 2004-08-30 16:13:44 EDT
Just clearing out old bugs here. This one has been fixed for a long
time. Current version is mgetty-1.1.31-2 .

Note You need to log in before you can comment on or make changes to this bug.