Bug 199455 - authinfo feature is broken in sendmail-8.13.7-2.fc5.1
authinfo feature is broken in sendmail-8.13.7-2.fc5.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 13:41 EDT by Vadym Chepkov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 05:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2006-07-19 13:41:20 EDT
After upgrade to sendmail-8.13.7-2.fc5.1 authinfo feature is broken.
Sendmail ignores authinfo.db probably due to permission issue.

# cd /etc/mail
# touch authinfo
# make
makemap: error opening type hash map authinfo.db: Permission denied
make: *** [authinfo.db] Error 73
Comment 1 Vadym Chepkov 2006-07-19 13:47:44 EDT
When authinfo.db belongs to root:
echo "/map authinfo AuthInfo:outgoing.verizon.net" | sendmail -bt 
responce is:
> map_lookup: authinfo (AuthInfo:outgoing.verizon.net) returns ...

If it belongs to smmsp:
> Map named "authinfo" not open
Comment 2 shrek-m 2006-07-19 19:17:14 EDT
the same happens with the fc4 update.
sendmail-8.13.7-2.fc4.1

see the error mail
<snip>
451 4.0.0 hash map "authinfo": unsafe map file /etc/mail/authinfo.db: Permission
denied
</snip>

the pernmissions after the update or every new sendmail start
# ll authinfo*
-rw-------  1 root  root    127 25. Jan 17:36 authinfo
-rw-r-----  1 smmsp smmsp 12288 25. Jan 17:36 authinfo.db
# chown root:root authinfo.db
# ll authinfo*
-rw-------  1 root root   127 25. Jan 17:36 authinfo
-rw-r-----  1 root root 12288 25. Jan 17:36 authinfo.db

now all is ok until a reboot or sendmail restart.
Comment 3 shrek-m 2006-07-20 14:42:31 EDT
thanks,
fedora-updates are becoming more and more fedora-updates-testing.

you should think about the state of the fedora update process.
bad sendmail updates, bas squirrelmail updates, bad kernel updates, bad squid
updates within a few weeks.
the mirrors are often slow and not up2date.

bye, this was my last fedora installation for a non-commercial organization.
and rhel ? no thanks !
Comment 4 shrek-m 2006-07-21 05:12:21 EDT
hi tim woerner,

i will remove my line `chown root:root /etc/mail/authinfo.db` in rc.local
without breaking  authinfo  as soon as possible.

when can we expect a new fixed sendmail package ?

$ rpm -q --changelog sendmail | head -16
* Mi Jul 19 2006 Thomas Woerner <twoerner@redhat.com> 8.13.7-2.fc4.1
- using new syntax for access database (#177566)
- fixed failure message while shutting down sm-client (#119429)
  resolution: stop sm-client before sendmail
- fixed method to specify persistent queue runners (#126760)
- removed patch backup files from sendmail-cf tree (#152955)
- fixed missing dnl on SMART_HOST define (#166680)
- fixed wrong location of aliases and aliases.db file in aliases man page
  (#166744)
- enabled CipherList config option for sendmail (#172352)
- added user chowns for /etc/mail/authinfo.db and move check for cf files
  (#184341)
- fixed Makefile of vacation (#191396)
  vacation is not included in this sendmail package
- /var/log/mail now belongs to sendmail (#192850)
- using old pam_stack
Comment 5 Thomas Woerner 2006-07-21 05:16:52 EDT
I have built the new package yesterday, but it has not been pushed, yet.
Comment 6 shrek-m 2006-07-22 06:45:05 EDT
i have no access on the affected fc4 server for the next few weeks.

it seems that the bug is fixed in the new fc4 and fc5 updates which should
published next week.
the fixed rawhide package 8.13.7-3.1 (buggy was 8.13.7-3) seems to be ok with
one intervention.
previously affected installations have to change the "authinfo.db" owner:group
from  "smmsp:smmsp"  to  "root:root"
or remove "authinfo.db" and restart sendmail or execute `make -C /etc/mail`

please close the bug if the problem is solved.

thanks and have nice weeks
Comment 7 Fedora Update System 2006-07-22 15:06:21 EDT
sendmail-8.13.7-2.fc5.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.