Bug 199459 - doesn't write out partition tables
doesn't write out partition tables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 13:53 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 18:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-07-19 13:53:33 EDT
anaconda-11.1.0.60-1.i386.rpme:

I have a RHEL 4 install currently:

 /dev/hda1 /boot  ext3
 /dev/hda2 /      ext3
 <large chunk of free space>

I choose 'custom'. I create a new 2G primary partition /dev/hda3 for '/', format
as ext3.

I choose /dev/hda1 as /boot, choose 'do not format'.

When it comes time to format filesystems, I get:

 "An error occured trying to format /dev/hda3".

If I look at the drive, /dev/hda3 was never added to the partition table.
Comment 1 Jeremy Katz 2006-07-19 15:03:00 EDT
Any kernel messages about being unable to write it?  nothing here has really
changed...
Comment 2 Bill Nottingham 2006-07-19 15:04:48 EDT
Nope. From a brief look over tty2-4, it almost appears that it didn't even try.
What steps is it supposed to write?
Comment 3 Jeremy Katz 2006-07-19 15:23:54 EDT
The partition table should get saved in the turnOnFilesystems step -- the only
reason it wouldn't is if parted failed to write it out for some reason (or the
kernel failed to notice the write)
Comment 4 Bill Nottingham 2006-07-19 15:57:44 EDT
tty3 is...
moving (1) to step confirminstall
moving (1) to step install
moving (1) to step enablefilesystems
formatting / as ext3
Format command: ['/usr/sbin/mke2fs', '/tmp/hda3', '-i', '4096', '-j' ]
tty5 is...
mke2fs: No such device or address while trying to determine filesystem size

There is a lockdep warning about anaconda attempting to acquire
(&bdev->bd_mutex) while already holding the lock.

No other useful information, really.
Comment 5 Jeremy Katz 2006-07-19 16:04:09 EDT
I blame the kernel ;-)

What are you doing using regular IDE anyway? :P
Comment 6 Bill Nottingham 2006-07-19 16:08:20 EDT
Because the other testbox is ahci/ata_piix, which works even worse at the moment? :P

Comment 7 Jeremy Katz 2006-07-20 18:12:46 EDT
Actually, after more investigation, this is Peter's fault ;-)

The mpath startup code was calling into refreshDevices which then resets
everything to its "on-disk" state.  I've stopped it from doing that for now
which hopefully won't break mpath/dmraid

Note You need to log in before you can comment on or make changes to this bug.