Bug 199467 - Split off a zziplib-tools package
Split off a zziplib-tools package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zziplib (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 14:35 EDT by Gérard Milmeister
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 11:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2006-07-19 14:35:35 EDT
I just installed the package chess, which pulled in the
zziplib package. This package contains, besides the libraries,
many tools in the /usr/bin directory. I suggest to separate
these utilities into a zziplib-tools package, since most people
are not interested in these tools, when only the requirements
for the libraries are satisfied.
Comment 1 Matthias Saou 2006-07-24 11:03:36 EDT
This is done in the development package to be included in the next push. I've
also made a few other minor changes to the package :
- FC6 rebuild.
- Split off -utils sub-package (#199467). Could have been plain "zzip"?
- Have sub-packages require exact release too.
- Build require automake to make the aclocal-1.9 check happy.
- Use --enable-frame-pointer otherwise -g gets removed from the CFLAGS.

Note You need to log in before you can comment on or make changes to this bug.