Bug 199477 - Too many systems registered using this registration token
Too many systems registered using this registration token
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 15:41 EDT by sabuj pattanayek
Modified: 2007-07-31 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 16:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sabuj pattanayek 2006-07-19 15:41:20 EDT
Description of problem:

I've setup an unlimited activation key on the satellite server. The kickstart
file uses this key when installing the system onto the machine. The system does
not properly register with the satellite server because both in the ks-post.log
file and when I try to manually register using up2date --register I get this
message if I try to use an existing active subscription:

Problem registering system:

Error Message:
    Maximum usage count of 10 reached
Error Class Code: 61
Error Class Info: Too many systems registered using this registration token
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

In any case only 1 other system is using the activation key.

Version-Release number of selected component (if applicable):

RHEL 4 AS U3 x86_64 client + Satellite Server 4.05

How reproducible:

every time

Steps to Reproduce:
1. Install the system using the kickstart using an unlimited activation key
2. The system doesn't automatically register itself with the satellite server so
try up2date --register .
3. Try using an already active subscription and the error message appears
  
Actual results:

Error message appears

Expected results:

System name should register in the satellite server along with hardware
information rather than just as "unknown" system.

Additional info:
Comment 1 sabuj pattanayek 2006-07-19 15:48:19 EDT
Another annoying thing is that up2date closes itself after this error message.
It should allow the user to try again or go back to enter the login information
again.
Comment 2 sabuj pattanayek 2007-07-31 16:10:38 EDT
I used up all the monitoring licenses on the remote server. The unlimited keys
were only for management and provisioning. Marking as resolved notabug.

Note You need to log in before you can comment on or make changes to this bug.