Bug 199487 - debugedit "Unhandled relocation" errors on ppc
debugedit "Unhandled relocation" errors on ppc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On: 199473
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 16:18 EDT by Roland McGrath
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0315
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:52:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2006-07-19 16:18:55 EDT
+++ This bug was initially created as a clone of Bug #199473 +++

See that bug for details.

This problem affects the creation of kernel-debuginfo (.ko.debug files) on
ppc/ppc64.  It exists in the RHEL4 rpm version as well.  I'm not really clear on
what is the material result of the corruption that failing to do these reloc
fixups does.  It seems like it should mangle some of the dwarf info's internal
pointers.  This could affect systemtap use on ppc64 kernels on RHEL4.

The fact that no corruption has been noticed might mean that it happens to be
harmless in these particular builds, or that it will always be harmless due to
some quirk of the kernel build that will persist, or that we just have not come
across a place that it bit in using systemtap so far.
Comment 1 Roland McGrath 2006-07-19 16:21:43 EDT
Oh, the upshot was supposed to be that a fixed RHEL4 rpm in the buildroots for
the next RHEL4 update's kernel builds will be required to get the fix in place.
Comment 2 Paul Nasrat 2006-08-08 18:08:30 EDT
Obvious fix, we should include this in 4.5
Comment 3 RHEL Product and Program Management 2006-08-18 11:03:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Red Hat Bugzilla 2007-05-01 18:52:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0315.html

Note You need to log in before you can comment on or make changes to this bug.