Bug 199548 - without removing package showing success
Summary: without removing package showing success
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-20 10:06 UTC by A S Alam
Modified: 2014-01-21 22:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 20:53:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description A S Alam 2006-07-20 10:06:04 UTC
Description of problem:
when tried to Remove (multiple) package (version), yum is showing the 
"Removed" and "Complete", but package is not removed

Version-Release number of selected component (if applicable):
yum-2.9.3-1

Additional Information:
1) scim-libs has 4 different version installed on machine
2) yum is showing error message, but till it showing "Removed"


OUTPUTs are following:
----------------------------------------------
root@aalam fonts]# rpm -qa | grep "scim-libs"
scim-libs-1.4.4-19
scim-libs-1.4.4-18
scim-libs-1.4.4-17
scim-libs-1.4.4-24.fc6
[root@aalam fonts]# yum remove scim-libs-1.4.4-18
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package scim-libs.i386 0:1.4.4-18 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 scim-libs               i386       1.4.4-18         installed         1.8 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Removing  : scim-libs                    ######################### [1/1]
/usr/bin/update-gtk-immodules: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: No such file or directory
error: %postun(scim-libs-1.4.4-18.i386) scriptlet failed, exit status 1

Removed: scim-libs.i386 0:1.4.4-18
Complete!
[root@aalam fonts]# rpm -qa | grep "scim-libs"
scim-libs-1.4.4-19
scim-libs-1.4.4-18
scim-libs-1.4.4-17
scim-libs-1.4.4-24.fc6
---------------------------------------------------

Comment 1 Seth Vidal 2006-07-20 18:15:52 UTC
the problem here is a broken scriptlet, I'd love to know why rpm doesn't hand
back an error as a result of this transaction, though.


Comment 2 Jeremy Katz 2006-09-18 20:53:57 UTC
Because scriptlet errors are non-fatal for a transaction (for better or worse).
 And there's not really any way to sanely detect it


Note You need to log in before you can comment on or make changes to this bug.