Bug 199554 - rpmbuild sendmail fails when enable_pie is set to no
Summary: rpmbuild sendmail fails when enable_pie is set to no
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-20 12:11 UTC by Thomas Steudten
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 15:08:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Steudten 2006-07-20 12:11:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

In the sendmail.spec file set: %define enable_pie no

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Executing(%build): /bin/sh -e /export/space/tmp/rpm-tmp.92793
+ umask 022
+ cd /home/rpmbuild/rpm/BUILD
+ cd sendmail-8.13.7
+ cat
+ cat
+ cat
+ cat
+ cat
+ DIRS='libsmutil sendmail mailstats rmail praliases smrsh makemap'
+ DIRS='libmilter libsmutil sendmail mailstats rmail praliases smrsh makemap'
+ for i in '$DIRS'
+ pushd libmilter
~/rpm/BUILD/sendmail-8.13.7/libmilter ~/rpm/BUILD/sendmail-8.13.7
+ sh Build -f ../redhat.config.m4
Configuration: pfx=, os=Linux, rel=2.6.17, rbase=2, rroot=2.6, arch=alpha, sfx=,
variant=optimized
Using M4=/usr/bin/m4
Creating
/home/rpmbuild/rpm/BUILD/sendmail-8.13.7/obj.Linux.2.6.17.alpha/libmilter using
/home/rpmbuil
d/rpm/BUILD/sendmail-8.13.7/devtools/OS/Linux
Including ../redhat.config.m4
Making dependencies in
/home/rpmbuild/rpm/BUILD/sendmail-8.13.7/obj.Linux.2.6.17.alpha/libmilter
ln -f -s ../../libsm/errstring.c .
ln -f -s ../../libsm/strl.c .
rm -f sm_os.h
ln -f -s ../../include/sm/os/sm_os_linux.h sm_os.h
cc -M -I. -I../../sendmail   -I../../include  -I/usr/include/db4
-I/usr/kerberos/include -Wall -DXDEBU
G=0 -DTCPWRAPPERS -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1
-D_FFR_WORKAROUND_BROKEN_NAMESER
VERS -D_FFR_SMTP_SSL -D_FFR_TLS_1 -DSASL=2 -D_FFR_UNSAFE_SASL
-DSM_CONF_LDAP_MEMFREE=1 -DNOT_SENDMAIL 
-Dsm_snprintf=snprintf -D_FFR_MILTER_ROOT_UNSAFE -D_REENTRANT main.c engine.c
listener.c handler.c com
m.c smfi.c signal.c sm_gethost.c errstring.c strl.c    >> Makefile
Making in /home/rpmbuild/rpm/BUILD/sendmail-8.13.7/obj.Linux.2.6.17.alpha/libmilter
cc `-O2 -g -mieee -mcpu=pca56  -Wa,-mpca56,-m21164pc  --param 
inline-unit-growth=10000' -I. -I../../s
endmail   -I../../include  -I/usr/include/db4 -I/usr/kerberos/include -Wall
-DXDEBUG=0 -DTCPWRAPPERS -
DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1
-D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SS
L -D_FFR_TLS_1 -DSASL=2 -D_FFR_UNSAFE_SASL -DSM_CONF_LDAP_MEMFREE=1
-DNOT_SENDMAIL -Dsm_snprintf=snpri
ntf -D_FFR_MILTER_ROOT_UNSAFE -D_REENTRANT -DXP_MT   -c -o main.o main.c
/bin/sh: -c: line 0: unexpected EOF while looking for matching `''
/bin/sh: -c: line 1: syntax error: unexpected end of file
make: *** [main.o] Error 2
error: Bad exit status from /export/space/tmp/rpm-tmp.92793 (%build)


RPM build errors:
    Bad exit status from /export/space/tmp/rpm-tmp.92793 (%build)


Expected results: clean build

Additional info: sendmail-8.13.7-2.fc5.1.src.rpm

Comment 1 Thomas Steudten 2006-07-20 13:01:39 UTC
This looks like a side-effect and depends not on the pie setting.

On the other hand I don't know why you use a tripple qouting here:

define(\`confOPTIMIZE', \`\`\`${RPM_OPT_FLAGS}''')

With this patch, it works for me:

--- sendmail.spec.orig  2006-07-20 14:37:35.000000000 +0200
+++ sendmail.spec       2006-07-20 14:37:54.000000000 +0200
@@ -150,7 +150,7 @@
 # generate redhat config file
 cat > redhat.config.m4 << EOF
 define(\`confMAPDEF', \`-DNEWDB -DNIS -DHESIOD -DMAP_REGEX -DSOCKETMAP
-DNAMED_BIND=1')
-define(\`confOPTIMIZE', \`\`\`${RPM_OPT_FLAGS}''')
+define(\`confOPTIMIZE', \`${RPM_OPT_FLAGS}')
 define(\`confENVDEF', \`-I/usr/include/db4 -I/usr/kerberos/include -Wall
-DXDEBUG=0 -DTCPWRAPPERS -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1
-D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SSL -D_FFR_TLS_1')
 define(\`confLIBDIRS', \`-L/usr/kerberos/%{_lib}')
 define(\`confLIBS', \`-lnsl -lwrap -lhesiod -lcrypt -ldb')


Comment 2 Thomas Woerner 2006-07-20 13:26:01 UTC
The package sendmail-8.13.7-2.fc5.2 was build on FC-5 and there was no error at
all. So where are you rebuilding this package?


Note You need to log in before you can comment on or make changes to this bug.