Bug 199558 - traceback
traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 199712 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-20 08:48 EDT by Florian La Roche
Modified: 2014-01-21 17:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 14:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Check for the log device first (1.02 KB, patch)
2006-07-20 14:19 EDT, James Bowes
no flags Details | Diff

  None (edit)
Description Florian La Roche 2006-07-20 08:48:13 EDT
Description of problem:

This happens if yum is called todo updates right in the %post section of
an install. Maybe if /dev/log is not available, this could stay left out
automatically?

regards,

Florian La Roche


Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 201, in getOptionsConfig
    self.conf.errorlevel, self.conf.debuglevel)
  File "/usr/lib/python2.4/site-packages/yum/logginglevels.py", line 110, in
doLoggingSetup
    syslog = logging.handlers.SysLogHandler('/dev/log')
  File "/usr/lib/python2.4/logging/handlers.py", line 589, in __init__
    self._connect_unixsocket(address)
  File "/usr/lib/python2.4/logging/handlers.py", line 605, in _connect_unixsocket
    self.socket.connect(address)
  File "<string>", line 1, in connect
socket.error: (2, 'No such file or directory')
Error in atexit._run_exitfuncs:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Seth Vidal 2006-07-20 13:36:40 EDT
adding jbowes
Comment 2 James Bowes 2006-07-20 14:19:42 EDT
Created attachment 132758 [details]
Check for the log device first

This patch checks to see if the log device exists first, before trying to make
a syslog handler that speaks to it.

I first tried just catching the exception that is thrown, but it seems that the
SysLogHandler code ended up in a state after this exception that caused other
problems upon garbage collection.
Comment 3 Seth Vidal 2006-07-20 14:31:57 EDT
Patch looked sensible so I checked it in.
Thanks
Comment 4 James Bowes 2006-07-21 14:04:26 EDT
*** Bug 199712 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.