Bug 199642 - can't readlink in /proc/*/fd (selinux disabled)
Summary: can't readlink in /proc/*/fd (selinux disabled)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-20 23:00 UTC by Alexandre Oliva
Modified: 2015-01-04 22:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 04:12:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2006-07-20 23:00:10 UTC
ls -l /proc/PID/fd as root can't read fds from processes other than itself any
more.  /proc/self/fd works, /proc/PID/fd doesn't.  ditto for
/proc/PID/{cwd,root,exe}.  This breaks lsof badly.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2416.fc6

Comment 1 Dave Jones 2006-07-26 04:12:16 UTC
I think Roland fixed this bug last week.
Can't reproduce it on latest rawhide anyway



Note You need to log in before you can comment on or make changes to this bug.