Bug 199675 - xscreensaver - rd-bomb consitently bombs
xscreensaver - rd-bomb consitently bombs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xscreensaver (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 213296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 06:24 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0283
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 19:52:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xscreensaver-rd-bomb-crash.patch (587 bytes, patch)
2006-07-21 06:24 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-07-21 06:24:55 EDT
+++ This bug was initially created as a clone of Bug #144580 +++

Description of problem:

I have in logs now eight messages of this nature:

kernel: rd-bomb[19235]: segfault at 0000002a9568b000
          rip 0000000000403023 rsp 0000007fbfffeec0 error 6

Reported values are consistent with an exception of "rsp" which
moves a bit.

No idea if this happens on i386 or not.

<snip>

-- Additional comment from djuran@redhat.com on 2005-10-09 09:17 EST --
This seems to be fixed in xscreensaver-4.22-18 in rawhide
Comment 1 Bastien Nocera 2006-07-21 06:24:56 EDT
Created attachment 132794 [details]
xscreensaver-rd-bomb-crash.patch
Comment 2 Bastien Nocera 2006-07-21 06:27:37 EDT
To reproduce the problem:
1. Get to a local console on a 64-bit machine
2. Launch "/usr/X11R6/lib/xscreensaver/rd-bomb -root"
3. See it crash

The attached patch is a (simple!) backport from xscreensaver-4.22-18 and was
tested as fixing the problem.

Work-around is to disable the rd-bomb hack (remove the lines containing
"rd-bomb" in ~/.xscreensaver, or disable them in the screensaver preferences)
Comment 9 Ray Strode [halfline] 2007-01-17 15:00:30 EST
*** Bug 213296 has been marked as a duplicate of this bug. ***
Comment 12 Yan Tian 2007-02-14 02:50:37 EST
Only reproduced bug199675 on x86_64 system with xscreensaver-4.18-5.rhel4.11 and
verified it had been modified with xscreensaver-4.18-5.rhel4.12.

Cant reproduce bug199675 on ia64, ppc64 and s390 system with
xscreensaver-4.18-5.rhel4.11.
Comment 15 Red Hat Bugzilla 2007-05-07 19:52:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0283.html

Note You need to log in before you can comment on or make changes to this bug.