This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 199712 - yum fails if syslog isn't running
yum fails if syslog isn't running
Status: CLOSED DUPLICATE of bug 199558
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 11:11 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 14:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-07-21 11:11:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2006-07-21 11:12:48 EDT
  File "/usr/share/yum-cli/cli.py", line 201, in getOptionsConfig
    self.conf.errorlevel, self.conf.debuglevel)
  File "/usr/lib/python2.4/site-packages/yum/logginglevels.py", line 110, in
doLoggingSetup
    syslog = logging.handlers.SysLogHandler('/dev/log')
  File "/usr/lib/python2.4/logging/handlers.py", line 589, in __init__
    self._connect_unixsocket(address)
  File "/usr/lib/python2.4/logging/handlers.py", line 605, in _connect_unixsocket
    self.socket.connect(address)
  File "<string>", line 1, in connect
socket.error: (2, 'No such file or directory')
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib/python2.4/logging/__init__.py", line 1333, in shutdown
    h.close()
  File "/usr/lib/python2.4/logging/handlers.py", line 630, in close
    if self.unixsocket:
AttributeError: SysLogHandler instance has no attribute 'unixsocket'
Error in sys.exitfunc:
Traceback (most recent call last):
  File "/usr/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
    func(*targs, **kargs)
  File "/usr/lib/python2.4/logging/__init__.py", line 1333, in shutdown
    h.close()
  File "/usr/lib/python2.4/logging/handlers.py", line 630, in close
    if self.unixsocket:
AttributeError: SysLogHandler instance has no attribute 'unixsocket'

This is with yum-2.9.3-1.
Comment 2 James Bowes 2006-07-21 14:04:10 EDT
This appears to be the same problem from bug 199558. Marking as a duplicate.

BTW, we now first check to see if /dev/log exists before trying to create a
SysLogHandler

*** This bug has been marked as a duplicate of 199558 ***

Note You need to log in before you can comment on or make changes to this bug.