Bug 199800 - BuildRequires pwlib-devel is 1.10.0, should be 1.10.1
BuildRequires pwlib-devel is 1.10.0, should be 1.10.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-22 05:12 EDT by Jan Kratochvil
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: ekiga-2.0.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 12:00:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2006-07-22 05:12:09 EDT
Description of problem:
BuildRequires is now:
BuildRequires: pwlib-devel >= 1.10.0
but it should be:
BuildRequires: pwlib-devel >= 1.10.1

Version-Release number of selected component (if applicable):
ekiga-2.0.2-1.1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 5
2. yum install pwlib-devel installs pwlib-devel-1.10.0
3. rpmbuild --rebuild ekiga-2.0.2-1.1.src.rpm
  
Actual results:
checking for PWLib version... configure: error: Sorry but the recommended PWLib
version is 1.10.1
error: Bad exit status from /var/tmp/rpm-tmp.17773 (%build)

Expected results:
error: Failed build dependencies:
        pwlib-devel >= 1.10.1 is needed by ekiga-2.0.2-1.1.i386

Additional info:
Comment 1 Hans Ulrich Niedermann 2006-07-24 12:18:14 EDT
The same problem appears with opal: The source code requires 2.2.2, but the spec
file requires only 2.2.1.
Comment 2 Hans Ulrich Niedermann 2006-07-28 09:56:12 EDT
Ahem. Just to clarify my last comment:

ekiga-2.0.2-1.1 does in fact require pwlib-devel >= 1.10.1 AND opal-devel >=
2.2.2 to build, while the SPEC file only specifies requiring pwlib-devel >=
1.10.0 and opal-devel >= 2.2.1 to build, respectively.
Comment 3 Hans Ulrich Niedermann 2006-08-13 22:29:07 EDT
Mock users can add this to their /etc/mock/defaults.cfg:

# Workaround for https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199800
config_opts['more_buildreqs']['ekiga-2.0.2-1.1'] = [ 'pwlib-devel >= 1.10.1',
'opal-devel >= 2.2.2' ]
Comment 4 Daniel Veillard 2006-11-02 12:00:10 EST
Should be fixed in rawhide with ekiga-2.0.3-3.fc7 when it gets pushed soonish:

-BuildRequires: pwlib-devel >= 1.10.0
-BuildRequires: opal-devel >= 2.2.1
+BuildRequires: pwlib-devel >= 1.10.2
+BuildRequires: opal-devel >= 2.2.3

  thanks !

Daniel

Note You need to log in before you can comment on or make changes to this bug.