Bug 199826 - Suspending cluster mirrors can cause indefinite hang
Suspending cluster mirrors can cause indefinite hang
Status: CLOSED WORKSFORME
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cmirror (Show other bugs)
4
All Linux
high Severity high
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks: 199185
  Show dependency treegraph
 
Reported: 2006-07-22 14:21 EDT by Jonathan Earl Brassow
Modified: 2010-01-11 21:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 16:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2006-07-22 14:21:11 EDT
When doing various operations on cluster mirrors with clvmd, the cluster mirror
will be suspended on all nodes before performing LVM metadata operations.

It is possible for the cluster log server to suspend all its mirror devices
before the other machines have completed suspending.  The other machines will
issue their last requests to the log server before suspending, but the server
will block trying to write to the log device because it has already suspended
them.  The server will not be able to continue until its log device is
unsuspended - which from the point of clvmd, can not happen until all nodes are
suspended.  The result is an complete LVM lock-up.

The fix is to allow the server to migrate during suspension to those nodes whose
log device is not yet suspended.
Comment 1 Corey Marthaler 2008-06-30 16:05:47 EDT
Closing this bug...

Note You need to log in before you can comment on or make changes to this bug.