Bug 199835 - Copy and paste can casue Nautilus to crash
Summary: Copy and paste can casue Nautilus to crash
Status: CLOSED DUPLICATE of bug 200033
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: freetype   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Behdad Esfahbod
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 199397 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-23 03:03 UTC by Ian Laurie
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:46:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Laurie 2006-07-23 03:03:28 UTC
Description of problem:
Copy and paste can casue Nautilus to crash.  It happens on multiple boxes with
RHEL4.

Version-Release number of selected component (if applicable):
nautilus-2.8.1-4

How reproducible:
I was under the impression it was now and then, but today I can reproduce the
problem at will, and it is consistent.

Steps to Reproduce:
1. Login as root (run level 5)
2. Right click on a file and select copy.
3. Move to another location and right click and select paste.
4. Nautilus crashes if the file already exists. 
  
Actual results:
Nautilus crashes; sometimes you get asked if you want to restart the
application, at other times you don't, but the nautilus automatically does restart.

Expected results:
Should ask if you want to overwrite the file... and then do it.


Additional info:
I am 99.99% certain the latest wave of updates causes this problem.  I had this
problem on one RHEL4 box but did NOT have it on another.... until I ran up2date. 

I believe the latest wave of updates were to freetype, gimp and libwmf.

I'd class this issue as quite serious as it represents a major loss of
functionality, and results in an important Gnome component crashing.

Comment 1 Ian Laurie 2006-07-23 03:51:12 UTC
On the second box, I backed out of the latest wave of updates by using 
rpm -U --force <package> and using the binary packages from the original
iso set of CDs.  One package at a time, and restarting Gnome each time.

The guilty update seems to be freetype* (4 rpms in total).

I then backdated just the 4 freetype packages on the first box and
it fixed the problem there also.

Obviously that doesn't mean the bug is in freetype.... I am fairly certain
I've seen this problem before on RHEL4, but it happened infrequently.  The
latest freetype just makes it happen every time.


Comment 2 Ian Laurie 2006-07-23 04:14:47 UTC
There is a backtrace of the crash on GNOME's site:

    http://bugzilla.gnome.org/show_bug.cgi?id=348376

Hope this helps.


Comment 3 Owen Taylor 2006-07-24 21:43:24 UTC
Reassigning appropriately.

Comment 4 Ray Strode [halfline] 2006-07-27 17:46:32 UTC

*** This bug has been marked as a duplicate of 200033 ***

Comment 5 Behdad Esfahbod 2006-07-27 20:52:16 UTC
*** Bug 199397 has been marked as a duplicate of this bug. ***

Comment 6 Behdad Esfahbod 2006-07-27 21:07:20 UTC

*** This bug has been marked as a duplicate of 200033 ***


Note You need to log in before you can comment on or make changes to this bug.