Bug 199839 - missing *.pyc files after yum update
missing *.pyc files after yum update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 01:38 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 14:03:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2006-07-23 01:38:55 EDT
Description of problem:
After upgrading from an installed package to a newer version of the package,
some .pyc files are missing when querying the rpm database. Previous bugs were
filed for other s-c-* packages. This package still exhibits the problem.
The problem seems to happen because some files that are already owned by the
package are rm *.pyc during the cleanup stage of rpm.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.7-2

How reproducible:
Upgrade package versions via yum update. verify packages with rpm.

Steps to Reproduce:
1. update system using yum or pup
2.rpm -qaV |grep missing >rpm-missing.txt
3. review file content of rpm-missing.txt
  
Actual results:
Missing *.pyc files reported. The query was performed as root.

Expected results:
No problems with rpm package.

Additional info:

If this bug has been reported before. It is not a problem resolved. There were
no hits using the default query.
Comment 1 Paul Nasrat 2006-08-14 14:03:21 EDT
1.2.7-2 has the fixed scriptlet, sadly the *.pyc will be removed on the preun of
the older package so there isn't much we can do here.

Note You need to log in before you can comment on or make changes to this bug.