Bug 19985 - Can't print to smb printer
Summary: Can't print to smb printer
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-29 11:37 UTC by mike
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-29 11:37:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mike 2000-10-29 11:37:38 UTC
I have a network printer on a Win 98 machine.  I can print to it using
smbclient.  I used printtool to setup a printcap entry for it and tried to
print using it (lpr, Gedit, etc.).  The results are the same in all cases:

[mike@kitchenstadium mike]$ lpr -Pepson .bash_profile
Status Information:
 sending job 'mike@localhost+346' to epson@localhost
 connecting to 'localhost', attempt 1
 connected to 'localhost'
 requesting printer epson@localhost
 job 'mike@localhost+346' transfer to epson@localhost failed
  error 'NONZERO RFC1179 ERROR CODE FROM SERVER' with ack 'ACK_FAIL'
  sending str '^Bepson' to epson@localhost
 error msg: 'spool queue for 'epson' does not exist on server
localhost.localdomain'
 error msg: '   non-existent printer or you need to run 'checkpc -f''
[mike@kitchenstadium mike]$

I think the filter isnt' getting $PRINTER_TYPE set properly by the caller,
because I don't ever see smbclient invoked (although it could be coming and
going really fast).

My /etc/printcap is:

##PRINTTOOL3## SMB uniprint NAxNA letter {} U_EpsonStylusColor stc740p {}
epson:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :if=/var/spool/lpd/lp/filter:\
        :af=/var/spool/lpd/lp/acct:\
        :lp=/dev/null:


I have LPRng and rhs-printfilters-1.81-1 installed

Thanks,
mike.

Comment 1 mike 2000-11-01 00:38:17 UTC
Not a bug.  I had something else going on; lpd wasn't being restarted by
printtool.  Killing and restarting it manually worked.


Note You need to log in before you can comment on or make changes to this bug.