Bug 1998535 - Cannot create desktop items
Summary: Cannot create desktop items
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-desktop
Version: 34
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2003079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-27 13:50 UTC by Frank McCormick
Modified: 2021-09-24 20:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-10 16:04:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Frank McCormick 2021-08-27 13:50:27 UTC
Description of problem:
Can't edit any desktop items

Version-Release number of selected component (if applicable):
1.26

How reproducible:
Evey time

Steps to Reproduce:
1.Try to edit a desktop item 
2.
3.

Actual results:
Nothing happens

Expected results:


Additional info:
Extract from .xsession-errors

mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.702: Unable to load resource for composite template for type 'PanelDItemEditor': The resource at “/org/mate/panel/panel-ditem-editor-dialog.ui” does not exist

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.702: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.702: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.703: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_widget_init_template: assertion 'template != NULL' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_box_pack: assertion 'GTK_IS_BOX (box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_combo_box_get_active_iter: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_widget_show: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_widget_show: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.732: gtk_combo_box_set_model: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_cell_layout_pack_start: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_cell_layout_set_attributes: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_combo_box_set_active: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_combo_box_set_active: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_combo_box_get_model: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:2995): Gtk-CRITICAL **: 09:28:31.733: gtk_tree_model_get_iter_first: assertion 'GTK_IS_TREE_MODEL (tree_model)' failed
**
ERROR:panel-ditem-editor.c:628:panel_ditem_editor_setup_ui: code should not be reached

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: Unable to load resource for composite template for type 'PanelDItemEditor': The resource at “/org/mate/panel/panel-ditem-editor-dialog.ui” does not exist

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.434: gtk_widget_class_bind_template_child_full: assertion 'widget_class->priv->template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_widget_init_template: assertion 'template != NULL' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_box_pack: assertion 'GTK_IS_BOX (box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_combo_box_get_active_iter: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_widget_show: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_widget_show: assertion 'GTK_IS_WIDGET (widget)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.463: gtk_combo_box_set_model: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_cell_layout_pack_start: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_cell_layout_set_attributes: assertion 'GTK_IS_CELL_LAYOUT (cell_layout)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_combo_box_set_active: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_combo_box_set_active: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_combo_box_get_model: assertion 'GTK_IS_COMBO_BOX (combo_box)' failed

(mate-desktop-item-edit:3079): Gtk-CRITICAL **: 09:28:45.464: gtk_tree_model_get_iter_first: assertion 'GTK_IS_TREE_MODEL (tree_model)' failed
**
ERROR:panel-ditem-editor.c:628:panel_ditem_editor_setup_ui: code should not be reached

Comment 1 Wolfgang Ulbrich 2021-08-27 15:02:22 UTC
Was the system restarted after update?

Comment 2 Frank McCormick 2021-08-27 16:52:26 UTC
Yes, rebooted twice.

Comment 3 Wolfgang Ulbrich 2021-08-27 18:53:45 UTC
Hmm, does this match you package list?

```
[root@f32-test rave]# rpm -qa libmate* caja* engrampa* atril* pluma* mozo* python3-caja mate* 
mate-themes-3.22.22-1.fc34.noarch
mate-user-admin-1.6.1-1.fc34.x86_64
mate-desktop-libs-1.26.0-1.fc34.x86_64
mate-utils-common-1.26.0-1.fc34.noarch
caja-extensions-common-1.26.0-1.fc34.noarch
libmateweather-data-1.26.0-1.fc34.noarch
libmateweather-1.26.0-1.fc34.x86_64
mate-control-center-filesystem-1.26.0-1.fc34.x86_64
libmatekbd-1.26.0-1.fc34.x86_64
caja-schemas-1.26.0-1.fc34.x86_64
caja-core-extensions-1.26.0-1.fc34.x86_64
caja-1.26.0-1.fc34.x86_64
mate-menus-libs-1.26.0-1.fc34.x86_64
mate-menus-1.26.0-1.fc34.x86_64
mate-panel-libs-1.26.0-1.fc34.x86_64
mate-panel-1.26.0-1.fc34.x86_64
libmatemixer-1.26.0-1.fc34.x86_64
atril-libs-1.26.0-1.fc34.x86_64
atril-1.26.0-1.fc34.x86_64
mate-settings-daemon-1.26.0-1.fc34.x86_64
mate-control-center-1.26.0-1.fc34.x86_64
mate-notification-daemon-1.26.0-1.fc34.x86_64
mate-user-guide-1.26.0-1.fc34.noarch
mate-desktop-1.26.0-1.fc34.x86_64
mate-polkit-1.26.0-1.fc34.x86_64
caja-actions-doc-1.26.0-1.fc34.noarch
pluma-data-1.26.0-1.fc34.noarch
pluma-1.26.0-1.fc34.x86_64
caja-actions-1.26.0-1.fc34.x86_64
mate-session-manager-1.26.0-1.fc34.x86_64
mate-system-monitor-1.26.0-1.fc34.x86_64
atril-caja-1.26.0-1.fc34.x86_64
atril-thumbnailer-1.26.0-1.fc34.x86_64
mate-media-1.26.0-1.fc34.x86_64
mate-applets-1.26.0-1.fc34.x86_64
mate-dictionary-1.26.0-1.fc34.x86_64
mate-power-manager-1.26.0-1.fc34.x86_64
mate-sensors-applet-1.26.0-1.fc34.x86_64
mozo-1.26.0-1.fc34.noarch
mate-menus-preferences-category-menu-1.26.0-1.fc34.x86_64
mate-screensaver-1.26.0-1.fc34.x86_64
caja-image-converter-1.26.0-1.fc34.x86_64
caja-open-terminal-1.26.0-1.fc34.x86_64
caja-sendto-1.26.0-1.fc34.x86_64
caja-wallpaper-1.26.0-1.fc34.x86_64
caja-xattr-tags-1.26.0-1.fc34.x86_64
engrampa-1.26.0-1.fc34.x86_64
mate-disk-usage-analyzer-1.26.0-1.fc34.x86_64
mate-screenshot-1.26.0-1.fc34.x86_64
mate-search-tool-1.26.0-1.fc34.x86_64
mate-system-log-1.26.0-1.fc34.x86_64
mate-terminal-1.26.0-1.fc34.x86_64
mate-icon-theme-1.26.0-1.fc34.noarch
mate-calc-1.26.0-1.fc34.x86_64
mate-backgrounds-1.26.0-1.fc34.noarch
```

Comment 4 Frank McCormick 2021-08-27 20:16:58 UTC
I'm bleary-eyed for comparing the lists but they appear to be the same

[frank@fedora ~]$ rpm -qa libmate* caja* engrampa* atril* pluma* mozo* python3-caja mate*
mate-user-admin-1.6.0-1.fc34.x86_64
mate-themes-3.22.22-1.fc34.noarch
mate-menu-20.04.3-5.fc34.noarch
mate-desktop-libs-1.26.0-1.fc34.x86_64
mate-utils-common-1.26.0-1.fc34.noarch
caja-extensions-common-1.26.0-1.fc34.noarch
libmateweather-data-1.26.0-1.fc34.noarch
libmateweather-1.26.0-1.fc34.x86_64
mate-control-center-filesystem-1.26.0-1.fc34.x86_64
libmatekbd-1.26.0-1.fc34.x86_64
caja-schemas-1.26.0-1.fc34.x86_64
caja-core-extensions-1.26.0-1.fc34.x86_64
caja-1.26.0-1.fc34.x86_64
mate-menus-libs-1.26.0-1.fc34.x86_64
mate-menus-1.26.0-1.fc34.x86_64
libmatemixer-1.26.0-1.fc34.x86_64
atril-libs-1.26.0-1.fc34.x86_64
atril-1.26.0-1.fc34.x86_64
mate-settings-daemon-1.26.0-1.fc34.x86_64
mate-control-center-1.26.0-1.fc34.x86_64
pluma-data-1.26.0-1.fc34.noarch
pluma-1.26.0-1.fc34.x86_64
mate-disk-usage-analyzer-1.26.0-1.fc34.x86_64
mate-screenshot-1.26.0-1.fc34.x86_64
mate-search-tool-1.26.0-1.fc34.x86_64
mate-system-log-1.26.0-1.fc34.x86_64
mate-user-guide-1.26.0-1.fc34.noarch
mate-polkit-1.26.0-1.fc34.x86_64
caja-actions-doc-1.26.0-1.fc34.noarch
mate-panel-libs-1.26.0-1.fc34.x86_64
mate-panel-1.26.0-1.fc34.x86_64
mate-dictionary-1.26.0-1.fc34.x86_64
mate-notification-daemon-1.26.0-1.fc34.x86_64
mate-desktop-1.26.0-1.fc34.x86_64
mate-system-monitor-1.26.0-1.fc34.x86_64
mate-utils-1.26.0-1.fc34.x86_64
mate-applets-1.26.0-1.fc34.x86_64
mate-media-1.26.0-1.fc34.x86_64
mate-power-manager-1.26.0-1.fc34.x86_64
caja-actions-1.26.0-1.fc34.x86_64
mate-session-manager-1.26.0-1.fc34.x86_64
atril-caja-1.26.0-1.fc34.x86_64
atril-thumbnailer-1.26.0-1.fc34.x86_64
mozo-1.26.0-1.fc34.noarch
mate-menus-preferences-category-menu-1.26.0-1.fc34.x86_64
mate-screensaver-1.26.0-1.fc34.x86_64
caja-image-converter-1.26.0-1.fc34.x86_64
caja-open-terminal-1.26.0-1.fc34.x86_64
caja-sendto-1.26.0-1.fc34.x86_64
caja-wallpaper-1.26.0-1.fc34.x86_64
caja-xattr-tags-1.26.0-1.fc34.x86_64
engrampa-1.26.0-1.fc34.x86_64
mate-terminal-1.26.0-1.fc34.x86_64
mate-icon-theme-1.26.0-1.fc34.noarch
mate-calc-1.26.0-1.fc34.x86_64
mate-backgrounds-1.26.0-1.fc34.noarch
[frank@fedora ~]$

Comment 5 Kevin Paetzold 2021-09-01 12:19:13 UTC
There actually seem to be MANY issues after installing mate 1.26.0-1.fc34 and also on fc35 and fc36 (rawhide).
mate 1.24.1-2.fc34 seems to work fine on all of above releases (34, 35, 36/rawhide).
crashes with stack traces from various components.  

This should be very easy to reproduce.   

1. Try creating a new launcher on desktop.
2. nothing seems to happen however there is stack trace of crashed processes in the journalctl log.

I can get the reported stack trace if really needed.  not at all convienent now because i had to downgraqde mate on every affected system or vm.

Comment 6 Kevin Paetzold 2021-09-01 12:22:07 UTC
This is list of 1.26.0-1 packages that produce the issues.

 libmatekbd                            x86_64  1.26.0-1.fc34     updates  189 k
 libmatemixer                          x86_64  1.26.0-1.fc34     updates  196 k
 libmateweather                        x86_64  1.26.0-1.fc34     updates   62 k
 libmateweather-data                   noarch  1.26.0-1.fc34     updates  2.8 M
 mate-applets                          x86_64  1.26.0-1.fc34     updates  9.2 M
 mate-backgrounds                      noarch  1.26.0-1.fc34     updates   44 M
 mate-calc                             x86_64  1.26.0-1.fc34     updates  1.1 M
 mate-control-center                   x86_64  1.26.0-1.fc34     updates  2.8 M
 mate-control-center-filesystem        x86_64  1.26.0-1.fc34     updates  8.2 k
 mate-dictionary                       x86_64  1.26.0-1.fc34     updates  7.0 M
 mate-disk-usage-analyzer              x86_64  1.26.0-1.fc34     updates  6.9 M
 mate-icon-theme                       noarch  1.26.0-1.fc34     updates   14 M
 mate-media                            x86_64  1.26.0-1.fc34     updates  299 k
 mate-menus                            x86_64  1.26.0-1.fc34     updates  111 k
 mate-menus-libs                       x86_64  1.26.0-1.fc34     updates   46 k
 mate-menus-preferences-category-menu  x86_64  1.26.0-1.fc34     updates  8.4 k
 mate-notification-daemon              x86_64  1.26.0-1.fc34     updates  180 k
 mate-panel                            x86_64  1.26.0-1.fc34     updates  2.3 M
 mate-panel-libs                       x86_64  1.26.0-1.fc34     updates   43 k
 mate-polkit                           x86_64  1.26.0-1.fc34     updates   88 k
 mate-power-manager                    x86_64  1.26.0-1.fc34     updates  5.9 M
 mate-screensaver                      x86_64  1.26.0-1.fc34     updates  4.6 M
 mate-screenshot                       x86_64  1.26.0-1.fc34     updates   48 k
 mate-search-tool                      x86_64  1.26.0-1.fc34     updates  6.9 M
 mate-sensors-applet                   x86_64  1.26.0-1.fc34     updates  311 k
 mate-settings-daemon                  x86_64  1.26.0-1.fc34     updates  707 k
 mate-system-log                       x86_64  1.26.0-1.fc34     updates  7.0 M
 mate-system-monitor                   x86_64  1.26.0-1.fc34     updates  2.2 M
 mate-terminal                         x86_64  1.26.0-1.fc34     updates  1.5 M
 mate-user-guide                       noarch  1.26.0-1.fc34     updates  8.9 M
 mate-utils                            x86_64  1.26.0-1.fc34     updates  7.3 k
 mate-utils-common                     noarch  1.26.0-1.fc34     updates  6.8 M



this is the list of packages that I downgraded to to get things working:


libmatekbd-1.24.1-2.fc34.x86_64.rpm
libmatemixer-1.24.1-2.fc34.x86_64.rpm
libmateweather-1.24.1-2.fc34.x86_64.rpm
libmateweather-data-1.24.1-2.fc34.noarch.rpm
mate-applets-1.24.1-3.fc34.x86_64.rpm
mate-backgrounds-1.24.2-3.fc34.noarch.rpm
mate-calc-1.24.2-1.fc34.x86_64.rpm
mate-control-center-1.24.2-1.fc34.x86_64.rpm
mate-control-center-filesystem-1.24.2-1.fc34.x86_64.rpm
mate-dictionary-1.24.0-3.fc34.x86_64.rpm
mate-disk-usage-analyzer-1.24.0-3.fc34.x86_64.rpm
mate-icon-theme-1.24.0-3.fc34.noarch.rpm
mate-media-1.24.1-2.fc34.x86_64.rpm
mate-menus-1.24.1-2.fc34.x86_64.rpm
mate-menus-libs-1.24.1-2.fc34.x86_64.rpm
mate-menus-preferences-category-menu-1.24.1-2.fc34.x86_64.rpm
mate-notification-daemon-1.24.2-1.fc34.x86_64.rpm
mate-panel-1.24.2-2.fc34.x86_64.rpm
mate-panel-libs-1.24.2-2.fc34.x86_64.rpm
mate-polkit-1.24.0-4.fc34.x86_64.rpm
mate-power-manager-1.24.3-1.fc34.x86_64.rpm
mate-screensaver-1.24.2-1.fc34.x86_64.rpm
mate-screenshot-1.24.0-3.fc34.x86_64.rpm
mate-search-tool-1.24.0-3.fc34.x86_64.rpm
mate-sensors-applet-1.24.1-2.fc34.x86_64.rpm
mate-settings-daemon-1.24.2-2.fc34.x86_64.rpm
mate-system-log-1.24.0-3.fc34.x86_64.rpm
mate-system-monitor-1.24.2-1.fc34.x86_64.rpm
mate-terminal-1.24.1-2.fc34.x86_64.rpm
mate-user-guide-1.24.0-3.fc34.noarch.rpm
mate-utils-1.24.0-3.fc34.x86_64.rpm
mate-utils-common-1.24.0-3.fc34.noarch.rpm

Comment 7 Wolfgang Ulbrich 2021-09-01 15:17:15 UTC
During 1.26 development many UI or gsettings key files was moved to a gresource file.
In this case the panel-ditem-editor-dialog code was moved to a UI file which will be loaded by a gresource file by glib
https://github.com/mate-desktop/mate-panel/commit/e9d2e89f5b66574401376c6ef64c856a6cee7f44

In another report the solution was to remove dconf settings from user account.
So please can you test if this issue exists in a fresh user account with default dconf settings?

Comment 8 Frank McCormick 2021-09-01 16:03:29 UTC
Same problem exists.(In reply to Wolfgang Ulbrich from comment #7)
> During 1.26 development many UI or gsettings key files was moved to a
> gresource file.
> In this case the panel-ditem-editor-dialog code was moved to a UI file which
> will be loaded by a gresource file by glib
> https://github.com/mate-desktop/mate-panel/commit/
> e9d2e89f5b66574401376c6ef64c856a6cee7f44
> 
> In another report the solution was to remove dconf settings from user
> account.
> So please can you test if this issue exists in a fresh user account with
> default dconf settings?

Created new user "tester"

same problem exists. Nothing was changed in "tester" account.
Tried to create desktop launcher. Crash.

I reported crash, but analysis was taking too long, I let it run
for 20 minutes but nothing happened.

Comment 9 Wolfgang Ulbrich 2021-09-01 17:04:17 UTC
(In reply to Kevin Paetzold from comment #5)
> There actually seem to be MANY issues after installing mate 1.26.0-1.fc34
> and also on fc35 and fc36 (rawhide).
> mate 1.24.1-2.fc34 seems to work fine on all of above releases (34, 35,
> 36/rawhide).
> crashes with stack traces from various components.  
> 
> This should be very easy to reproduce.   

I wish it would be easy to reproduce, yesterday i installed Mate 1.26 on a slow raspberry 3b+, but everything works well, same like all my other installations.
Well, i will make a complete rebuild of the MATE stack at fedora copr repo the next days. Maybe something was wrong with building the packages.

Comment 10 Wolfgang Ulbrich 2021-09-01 17:19:24 UTC
Ok, i can reproduce it with mate-panel from fedora repos.
But with my local build of mate-panel-1.26 the issue is gone, so i have a chance to dig down the issue.
For the moment try this local builds of mate-panel-1.26 https://www.dropbox.com/s/19w6wi28a8u1hp9/mate-panel-1.26-test.tar.xz?dl=0
to confirm that this will fix the issue.......or not.

Comment 11 Wolfgang Ulbrich 2021-09-01 17:37:39 UTC
Ok, forget my previous post, now i still run in this issue with my local build 1.26.0-12, too  :/

Comment 12 Wolfgang Ulbrich 2021-09-01 18:42:04 UTC
Can you please test this scratch build https://koji.fedoraproject.org/koji/taskinfo?taskID=74945580
This should fix this issue.

Comment 13 Frank McCormick 2021-09-01 19:04:25 UTC
Works here!! Thank you.

Comment 14 Kevin Paetzold 2021-09-02 11:46:30 UTC
seems to fix the issue for me.
i actually tested with an install from the f35 branch.

Comment 15 Fedora Update System 2021-09-02 14:38:49 UTC
FEDORA-2021-97c832f69c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-97c832f69c

Comment 16 Fedora Update System 2021-09-02 14:38:50 UTC
FEDORA-2021-c448dc55eb has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-c448dc55eb

Comment 17 Wolfgang Ulbrich 2021-09-02 14:41:13 UTC
I just did a new build for fedora.
Please test and leave karma.

Comment 18 Fedora Update System 2021-09-02 15:56:29 UTC
FEDORA-2021-97c832f69c has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-97c832f69c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-97c832f69c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-09-03 00:05:31 UTC
FEDORA-2021-c448dc55eb has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c448dc55eb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c448dc55eb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Wolfgang Ulbrich 2021-09-10 14:26:44 UTC
*** Bug 2003079 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2021-09-10 16:04:31 UTC
FEDORA-2021-c448dc55eb has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2021-09-24 20:14:23 UTC
FEDORA-2021-97c832f69c has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.