Bug 199892 (rhn411-hmmpretty) - RHN shows error 500 , sometimes.. hmm pretty.
Summary: RHN shows error 500 , sometimes.. hmm pretty.
Status: CLOSED CURRENTRELEASE
Alias: rhn411-hmmpretty
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Mike McCune
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 199445
TreeView+ depends on / blocked
 
Reported: 2006-07-24 04:37 UTC by Wade Mealing
Modified: 2007-04-18 17:46 UTC (History)
1 user (show)

Fixed In Version: rhn411
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 15:39:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception shown on customer facing site. (2.96 KB, text/plain)
2006-07-24 04:37 UTC, Wade Mealing
no flags Details

Description Wade Mealing 2006-07-24 04:37:18 UTC
Description of problem:

RHN shows internal error 500 on some logins, problem is not consistant. 
Difficult to reproduce.

Version-Release number of selected component (if applicable):

Current customer facing website.

How reproducible:

One out of 20 login attempts.. maybe.. Log in and out, for a  bit, try again
soon, maybe just close the page while logged in, then attempt to log in again.


Steps to Reproduce:
1. Visit rhn.redhat.com , log in.
2. close window ( do not log out )
3. visit http://rhn.redhat.com in same browser.
  
Actual results:

Error 500, see attachment.


Expected results:

RHN to display default login page.

Additional info:

Not reproducable every time.
I'm not going to clear my cache and cookies, because customers should not have
to "Clear cache and cookies".  We have html headers for setting for not caching
files (see META HTTP-EQUIV="PRAGMA" CONTENT="NO-CACHE" ) and also one can set a
time limit on cookies.

Comment 1 Wade Mealing 2006-07-24 04:37:19 UTC
Created attachment 132894 [details]
Exception shown on customer facing site.

Comment 2 Kevin A. Smith 2006-07-24 13:33:00 UTC
I think I see the cause of this. The LocalizationService does not handle calls
to getMessage() with a null messageId well. It should detect null messageIds and
return the results of a call to getMissingMessageString().

For anyone interested, look at the following lines in LocalizationService: 259,
621, and 314.

I have a fix for this on my box, just waiting for review.

Comment 3 Jesus M. Rodriguez 2006-08-02 15:39:03 UTC
This has been pushed to production already.

Comment 4 Beth Nackashi 2006-08-07 20:49:38 UTC
changing the current release from rhn4101 to rhn411


Note You need to log in before you can comment on or make changes to this bug.