Bug 199893 - CPUfreq-applet crashes on dual-core after resume
CPUfreq-applet crashes on dual-core after resume
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 01:13 EDT by Jeremy Fitzhardinge
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2006-07-24 01:13:38 EDT
Description of problem:
cpufreq-applet exits unexpectedly when using cpufreq to monitor CPU #1, resuming
a dual-core machine.

Version-Release number of selected component (if applicable):
gnome-applets-2.15.1.1-3.1

How reproducible:
always

Steps to Reproduce:
1. start cpufreq-applet monitoring CPU #1
2. suspend to ram
3. resume
 
Actual results:
cpufreq-applet crashes

Expected results:
doesn't crash

Additional info:
suspending a multi-cpu machine effectively hot-unplugs all cpus except CPU#0. 
On resume, the cpufreq-applet tries to read the /sys/devices/system/cpu/1/ files
before the CPU has been re-enabled, and then crashes when the open/read fails.
Comment 1 Matthew Miller 2007-04-06 14:25:10 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Ray Strode [halfline] 2007-08-14 11:45:44 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.