Bug 199899 - firstboot fails to load soundcard module and hangs system
firstboot fails to load soundcard module and hangs system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 03:27 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 14:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2006-07-24 03:27:14 EDT
Description of problem:
Firstboot comes up and fails to load the soundcard detection module with some
error about dbus. (Could not preserve ther error messages from VT1.) It goes
through all the loaded modules and then hangs (apparently forever.)


Version-Release number of selected component (if applicable):
firstboot-1.4.15-1


How reproducible:
twice now for me (always)


Steps to Reproduce:
1. install rawhide of 2006-07-23
2. reboot
3.
  
Actual results:
Firstboot comes up in GUI and connects (without RHGB in the mix!) but dumps
error traceback on VT1 about soundcard module and dbus.  Will allow operation
of all loaded modules, and sets the firstboot flags.  However, after all
existing modules have run, it just sits there (for more than 10 minutes)
and requires a X-server reset (ctrl-alt-bs) and the system is hung.  Rebooting
via <C-A-Del> results in a normal boot without firstboot running again.


Expected results:
Firstboot should not fail to load soundcard module,
and should exit cleanly.


Additional info:
testbed machine is Celeron(Coppermine)@600MHz on MSI-68xx mobo with
VIA chipset and on-board audio, video and NIC. (sound is snd-via82xx module)

Running s-c-soundcard from menu results in a good detection.
Comment 1 Chris Lumens 2006-07-24 10:14:23 EDT
Please attach /tmp/firstboot-crash.log.
Comment 2 G.Wolfe Woodbury 2006-07-24 11:31:17 EDT
Unfortunately, there isn't a /tmp/firstboot-crash.log file that I could find.
I looked for it to attach, but it wasn't there; the traceback appeared only on
vt1 and I couldn't capture it right.

I'll be doing another install in a couple of hours after my local mirror syncs
and I will look immediatly on the error occurring.  The hang seems to make
several things not work.
Comment 3 Chris Lumens 2006-07-24 13:14:41 EDT
For my future reference, this is what I'm seeing:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 466, in loadModules
    result = module.launch(self.doDebug)
  File "/usr/share/firstboot/modules/soundcard_gui.py", line 54, in launch
    cards = self.soundcardBackend.probeCards()
TypeError: probeCards() takes exactly 2 arguments (1 given)

system-config-soundcard runs fine itself after installation because that's a
completely different code path than the firstboot module.
Comment 4 Chris Lumens 2006-07-24 14:16:18 EDT
Also this:

Introspect error: The name org.freedesktop.Hal was not provided by any .service
files
module import of soundcard_gui failed: debug_bindings.DBusException
Comment 5 Chris Lumens 2006-07-24 14:30:34 EDT
firstboot needs to start after haldaemon.  Fixed.

Note You need to log in before you can comment on or make changes to this bug.