Bug 199901 - The View & Edit Download Actions is disable
Summary: The View & Edit Download Actions is disable
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords: Desktop
Depends On:
Blocks: 207528
TreeView+ depends on / blocked
 
Reported: 2006-07-24 07:38 UTC by Nicole Dai
Modified: 2018-04-11 15:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
download actions setting for .mp3 file (88.73 KB, image/png)
2006-07-24 07:38 UTC, Nicole Dai
no flags Details
download actions setting for .swf file (95.80 KB, image/png)
2006-07-24 07:40 UTC, Nicole Dai
no flags Details
download actions in Firefox 1.5.0.4 20060508 rawhide (109.81 KB, image/png)
2006-07-24 07:41 UTC, Nicole Dai
no flags Details

Description Nicole Dai 2006-07-24 07:38:58 UTC
Description of problem:
The View & Edit Download Actions is disable. In the test case, we tested .mp3
file and .swf file. 

Version-Release number of selected component (if applicable):
firefox-1.5.0.4-3

How reproducible:
Always

Steps to Reproduce:
1.Click an online .mp3 file, such as
'http://ftp.xiapu.com/MP3/Thank%20You%20Dido.mp3',it will pop up a dialog. Refer
to the first attachment.
2.In the dialog select 'Open with XXX (default)' and tick the 'Do this
automatically for files like this from now on'.
3.Click 'OK'.
4.Repeat the step1-3 with a .swf file, refer to the second attachment.
5.Open 'Edit'-'Preferences'-'Downloads'-'View & Edit Actions...'.
6.Check the Download Actions.
  
Actual results:
There is no records in the Download Actions.

Expected results:
There should has two records in the Download Actions. Refer to the third
attachment which was captured in Firefox 1.5.0.4 20060508 rawhide.

Additional info:
The bug was not found in Firefox 1.5.0.4 20060508 rawhide.

Comment 1 Nicole Dai 2006-07-24 07:38:58 UTC
Created attachment 132901 [details]
download actions setting for .mp3 file

Comment 2 Nicole Dai 2006-07-24 07:40:33 UTC
Created attachment 132902 [details]
download actions setting for .swf file

Comment 3 Nicole Dai 2006-07-24 07:41:47 UTC
Created attachment 132903 [details]
download actions in Firefox 1.5.0.4 20060508 rawhide

Comment 4 Nicole Dai 2006-07-31 05:09:16 UTC
The bug was still found in firefox-1.5.0.5-7.

Comment 5 Christopher Aillon 2006-09-25 19:23:15 UTC
I can't test the same swf you are using because you didn't include a link. 
However, this is probably because of HTTP headers.  Web sites can force
downloading as attachment using the Content-Disposition header.  This sounds
like what is happening.

Comment 6 Nicole Dai 2006-09-26 01:55:45 UTC
Could you pls have a look at Comment #3, I tested with same .swf file and same
action. If my operation was wrong, could you pls list the correct steps for
setting Download Actions? Thanks.

Comment 7 security 2006-12-07 17:37:34 UTC
Can confirm exists with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107
Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Comment 8 Matthew Miller 2007-04-06 18:45:00 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 9 Nicole Dai 2007-04-10 09:33:56 UTC
Still found the problem in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070325 Firefox/2.0.0.3

Comment 10 Matthew Miller 2007-04-10 15:49:57 UTC
Moving to devel as per comment #9.

Comment 11 Matěj Cepl 2007-12-20 16:47:20 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.