Bug 199904 - An endless loop was found in the download actions
An endless loop was found in the download actions
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
: Desktop
Depends On:
Blocks: 207529
  Show dependency treegraph
 
Reported: 2006-07-24 04:10 EDT by Nicole Dai
Modified: 2007-12-20 11:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
open an online .swf file (86.50 KB, image/png)
2006-07-24 04:10 EDT, Nicole Dai
no flags Details
An endless loop (57.24 KB, image/png)
2006-07-24 04:12 EDT, Nicole Dai
no flags Details

  None (edit)
Description Nicole Dai 2006-07-24 04:10:23 EDT
Description of problem:
An endless loop was found in the download actions. In the firefox which has not
flash plug-in, open an online .swf file, in the prompted dialog select 'Open
with Firefox Web Browser(default)' and tick 'Do this automatically for files
like this from now on', then click 'OK'. An endless loop occurred with numerous
new tabs or windows poped up. Refer to the attachment for details.

Version-Release number of selected component (if applicable):
firefox-1.5.0.4-3

How reproducible:
Always

Steps to Reproduce:
1.In the firefox which has not flash plug-in, open an online .swf file,such as
'http://www.blackboard.com/docs/LearningServices/Release6/Grade_Assignment.swf'.
2.In the prompted dialog select 'Open with Firefox Web Browser(default)' and
tick 'Do this automatically for files like this from now on', then click 'OK'.
3.
  
Actual results:
An endless loop occurred with numerous new tabs or windows poped up. Refer to
the attachments.

Expected results:

Additional info:
Did the test case in the firefox 1.5.0.4 20060508 rawhide, if there is no
plug-in to open .swf file, the .swf file will be saved to disk.
Comment 1 Nicole Dai 2006-07-24 04:10:24 EDT
Created attachment 132904 [details]
open an online .swf file
Comment 2 Nicole Dai 2006-07-24 04:12:08 EDT
Created attachment 132905 [details]
An endless loop
Comment 3 Nicole Dai 2006-07-31 01:09:56 EDT
The bug was still found in firefox-1.5.0.5-7.
Comment 4 Matthew Miller 2007-04-06 12:43:33 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Nicole Dai 2007-04-10 05:41:39 EDT
Still found the problem in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070325 Firefox/2.0.0.3
Comment 6 Matthew Miller 2007-04-10 11:50:21 EDT
Moving to devel as per comment #5.
Comment 7 Matěj Cepl 2007-12-20 11:47:18 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.