Bug 199936 - possible recursive locking detected: nfsd/8184
possible recursive locking detected: nfsd/8184
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 206712 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 10:38 EDT by Jay Turner
Modified: 2015-01-07 19:13 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 10:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2006-07-24 10:38:33 EDT
Description of problem:
With nfs-utils-1.0.8-5.1.fc6/kernel-2.6.17-1.2432.el5, I'm getting the following
in syslog:

Jul 24 09:35:11 test1082 mountd[8489]: authenticated mount request from
heisey.devel.redhat.com:981 for /tmp (/tmp)
Jul 24 09:35:19 test1082 kernel:
Jul 24 09:35:19 test1082 kernel: =============================================
Jul 24 09:35:19 test1082 kernel: [ INFO: possible recursive locking detected ]
Jul 24 09:35:19 test1082 kernel: ---------------------------------------------
Jul 24 09:35:19 test1082 kernel: nfsd/8481 is trying to acquire lock:
Jul 24 09:35:19 test1082 kernel:  (&inode->i_mutex){--..}, at:
[<ffffffff80265d5f>] mutex_lock+0x2a/0x2e
Jul 24 09:35:19 test1082 kernel:
Jul 24 09:35:19 test1082 kernel: but task is already holding lock:
Jul 24 09:35:19 test1082 kernel:  (&inode->i_mutex){--..}, at:
[<ffffffff80265d5f>] mutex_lock+0x2a/0x2e
Jul 24 09:35:19 test1082 kernel:
Jul 24 09:35:19 test1082 kernel: other info that might help us debug this:
Jul 24 09:35:19 test1082 kernel: 2 locks held by nfsd/8481:
Jul 24 09:35:19 test1082 kernel:  #0:  (hash_sem){----}, at:
[<ffffffff8848a4c2>] exp_readlock+0x10/0x12 [nfsd]
Jul 24 09:35:19 test1082 kernel:  #1:  (&inode->i_mutex){--..}, at:
[<ffffffff80265d5f>] mutex_lock+0x2a/0x2e
Jul 24 09:35:19 test1082 kernel:
Jul 24 09:35:19 test1082 kernel: stack backtrace:
Jul 24 09:35:19 test1082 kernel:
Jul 24 09:35:19 test1082 kernel: Call Trace:
Jul 24 09:35:19 test1082 kernel:  [<ffffffff8026e229>] show_trace+0xaa/0x23d
Jul 24 09:35:19 test1082 kernel:  [<ffffffff8026e3d1>] dump_stack+0x15/0x17
Jul 24 09:35:19 test1082 kernel:  [<ffffffff802a7784>] __lock_acquire+0x135/0xa54
Jul 24 09:35:19 test1082 kernel:  [<ffffffff802a8644>] lock_acquire+0x4b/0x69
Jul 24 09:35:19 test1082 kernel:  [<ffffffff80265bb9>]
__mutex_lock_slowpath+0xe5/0x261
Jul 24 09:35:19 test1082 kernel:  [<ffffffff80265d5f>] mutex_lock+0x2a/0x2e
Jul 24 09:35:19 test1082 kernel:  [<ffffffff88487517>]
:nfsd:nfsd_setattr+0x2e0/0x4f3
Jul 24 09:35:19 test1082 kernel:  [<ffffffff88488d1d>]
:nfsd:nfsd_create_v3+0x38c/0x544
Jul 24 09:35:19 test1082 kernel:  [<ffffffff8848efb3>]
:nfsd:nfsd3_proc_create+0x13d/0x153
Jul 24 09:35:19 test1082 kernel:  [<ffffffff884830fa>]
:nfsd:nfsd_dispatch+0xe3/0x1a9
Jul 24 09:35:19 test1082 kernel:  [<ffffffff883a99ce>]
:sunrpc:svc_process+0x44f/0x702
Jul 24 09:35:19 test1082 kernel:  [<ffffffff8848368c>] :nfsd:nfsd+0x1b6/0x32a
Jul 24 09:35:19 test1082 kernel:  [<ffffffff80260e1e>] child_rip+0x8/0x12
Jul 24 09:35:22 test1082 mountd[8489]: authenticated unmount request from
heisey.devel.redhat.com:988 for /tmp (/tmp)


Version-Release number of selected component (if applicable):


How reproducible:
spotty

Steps to Reproduce:
1. Had started nfs with a very simple export (/tmp exported to the world,
sync,rw) and mounted the export from another machine; unmounted the export and
shutdown nfs; the deadlock message occurred between the mount and unmount
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Gahagan 2006-08-04 10:11:19 EDT
I hit this during a run of stress-kernel as well, I think it happened right when
nfs-compile started:
[root@dhcp59-171 ~]# uname -a
Linux dhcp59-171.rdu.redhat.com 2.6.17-1.2507.el5 #1 SMP Wed Aug 2 11:16:52 EDT
2006 i686 i686 i386 GNU/Linux

Aug  3 18:05:46 dhcp59-171 kernel: ============================================
=
Aug  3 18:05:46 dhcp59-171 kernel: [ INFO: possible recursive locking detected
]
Aug  3 18:05:46 dhcp59-171 kernel: --------------------------------------------
-
Aug  3 18:05:46 dhcp59-171 kernel: nfsd/22622 is trying to acquire lock:
Aug  3 18:05:46 dhcp59-171 kernel:  (&inode->i_mutex){--..}, at: [<c06060d9>] m
utex_lock+0x21/0x24
Aug  3 18:05:46 dhcp59-171 kernel:
Aug  3 18:05:46 dhcp59-171 kernel: but task is already holding lock:
Aug  3 18:05:46 dhcp59-171 kernel:  (&inode->i_mutex){--..}, at: [<c06060d9>] m
utex_lock+0x21/0x24
Aug  3 18:05:46 dhcp59-171 kernel:
Aug  3 18:05:46 dhcp59-171 kernel: other info that might help us debug this:
Aug  3 18:05:46 dhcp59-171 kernel: 2 locks held by nfsd/22622:
Aug  3 18:05:46 dhcp59-171 kernel:  #0:  (hash_sem){..--}, at: [<f8d3c4fa>] exp
_readlock+0xd/0xf [nfsd]
Aug  3 18:05:47 dhcp59-171 kernel:  #1:  (&inode->i_mutex){--..}, at: [<c06060d
9>] mutex_lock+0x21/0x24
Aug  3 18:05:47 dhcp59-171 kernel:
Aug  3 18:05:47 dhcp59-171 kernel: stack backtrace:
Aug  3 18:05:47 dhcp59-171 kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x159
Aug  3 18:05:47 dhcp59-171 kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  3 18:05:47 dhcp59-171 kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  3 18:05:47 dhcp59-171 kernel:  [<c043b846>] __lock_acquire+0x773/0x997
Aug  3 18:05:48 dhcp59-171 kernel:  [<c043bfdb>] lock_acquire+0x4b/0x6c
Aug  3 18:05:48 dhcp59-171 kernel:  [<c0605f6a>] __mutex_lock_slowpath+0xbc/0x2
0a
Aug  3 18:05:48 dhcp59-171 kernel:  [<c06060d9>] mutex_lock+0x21/0x24
Aug  3 18:05:48 dhcp59-171 kernel:  [<f8d39d6f>] nfsd_setattr+0x2fb/0x4aa [nfsd
]
Aug  3 18:05:48 dhcp59-171 kernel:  [<f8d3b1fb>] nfsd_create_v3+0x31c/0x48c [nf
sd]
Aug  3 18:05:48 dhcp59-171 kernel:  [<f8d3fe2a>] nfsd3_proc_create+0x125/0x135
[nfsd]
Aug  3 18:05:49 dhcp59-171 kernel:  [<f8d360d4>] nfsd_dispatch+0xc0/0x178 [nfsd
]
Aug  3 18:05:49 dhcp59-171 kernel:  [<f8c5b7c3>] svc_process+0x3a4/0x5ee [sunrp
c]
Aug  3 18:05:49 dhcp59-171 kernel:  [<f8d365f6>] nfsd+0x197/0x2e1 [nfsd]
Aug  3 18:05:50 dhcp59-171 kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Aug  3 18:05:50 dhcp59-171 kernel: DWARF2 unwinder stuck at kernel_thread_helpe
r+0x5/0xb
Aug  3 18:05:50 dhcp59-171 kernel: Leftover inexact backtrace:
Aug  3 18:05:50 dhcp59-171 kernel:  [<c04057ea>] show_trace+0xd/0x10
Aug  3 18:05:50 dhcp59-171 kernel:  [<c0405903>] dump_stack+0x19/0x1b
Aug  3 18:05:50 dhcp59-171 kernel:  [<c043b846>] __lock_acquire+0x773/0x997
Aug  3 18:05:50 dhcp59-171 kernel:  [<c043bfdb>] lock_acquire+0x4b/0x6c
Aug  3 18:05:50 dhcp59-171 kernel:  [<c0605f6a>] __mutex_lock_slowpath+0xbc/0x2
0a
Aug  3 18:05:50 dhcp59-171 kernel:  [<c06060d9>] mutex_lock+0x21/0x24
Aug  3 18:05:50 dhcp59-171 kernel:  [<f8d39d6f>] nfsd_setattr+0x2fb/0x4aa [nfsd
]
Aug  3 18:05:51 dhcp59-171 Cerberus: Heartbeat: 7m40s
Aug  3 18:05:51 dhcp59-171 kernel:  [<f8d3b1fb>] nfsd_create_v3+0x31c/0x48c [nf
sd]
Aug  3 18:05:51 dhcp59-171 kernel:  [<f8d3fe2a>] nfsd3_proc_create+0x125/0x135
[nfsd]
Aug  3 18:05:51 dhcp59-171 kernel:  [<f8d360d4>] nfsd_dispatch+0xc0/0x178 [nfsd
]
Aug  3 18:05:51 dhcp59-171 kernel:  [<f8c5b7c3>] svc_process+0x3a4/0x5ee [sunrp
c]
Aug  3 18:05:51 dhcp59-171 kernel:  [<f8d365f6>] nfsd+0x197/0x2e1 [nfsd]
Aug  3 18:05:51 dhcp59-171 kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Comment 2 Jay Turner 2006-09-20 23:08:00 EDT
*** Bug 206712 has been marked as a duplicate of this bug. ***
Comment 3 Steve Dickson 2006-10-25 07:50:18 EDT
I believe this have been fixed by some recent fixes
to the lockdep code... Please see if still happens with
as B2 kernel.
Comment 4 Jay Turner 2006-10-25 10:32:25 EDT
I'm not longer seeing this messages with the latest RHEL5 trees (20061024.5)
which granted, have lockdep turns off, so not really sure if this actually was
resolved or not.

Note You need to log in before you can comment on or make changes to this bug.