Bug 200030 - crashes if compiling nessus-2.2.8
Summary: crashes if compiling nessus-2.2.8
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-24 21:51 UTC by XVilka
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 16:11:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
out file from gcc (91.77 KB, application/octet-stream)
2006-07-24 21:51 UTC, XVilka
no flags Details
out file from gcc (396.56 KB, application/octet-stream)
2006-07-24 21:56 UTC, XVilka
no flags Details

Description XVilka 2006-07-24 21:51:55 UTC
Description of problem:
internal compiler error: Illegal instruction

Version-Release number of selected component (if applicable):
gcc (GCC) 4.1.0 20060304 (Red Hat 4.1.0-3)

How reproducible:
try to compile file exec.c from nessus-installer-2.2.8.sh (official version from
the official nessus site)

Steps to Reproduce:
1. download nessus-installer-2.2.8.sh from the www.nessus.org
2. run # sh nessus-installer-2.2.8.sh
3. crash when installer trying to compile file exec.c
  
Actual results:

x -- Compiling
./gencode.c:83: warning: function definition has qualified void return type
./optimize.c: In function 'opt_loop':
./optimize.c:1581: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc7nJDV3.out file, please attach this to
your bugreport.
make[1]: *** [optimize.o] ÐÑибка 1
make: [pcap-make] ÐÑибка 2 (игноÑиÑована)
x -- Installing
libtool: install: `libpcap-nessus.la' is not a valid libtool archive
Try `libtool --help --mode=install' for more information.
make[1]: *** [install-libpcap-nessus.la] ÐÑибка 1
make: [pcap-install] ÐÑибка 2 (игноÑиÑована)
x - Compiling the NASL interpretor
x -- Configuring the sources for your system
x -- Compiling
nasl_packet_forgery.c: In function 'nasl_tcp_ping':
nasl_packet_forgery.c:1265: warning: assignment makes pointer from integer
without a cast
exec.c: In function 'nasl_exec':
exec.c:1700: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc6RxWWw.out file, please attach this to
your bugreport.
make[1]: *** [exec.o] ÐÑибка 1
make: *** [all] ÐÑибка 2
**** An error occured :/


Additional info:

Comment 1 XVilka 2006-07-24 21:51:56 UTC
Created attachment 132951 [details]
out file from gcc

Comment 2 XVilka 2006-07-24 21:56:44 UTC
Created attachment 132952 [details]
out file from gcc

Comment 3 Jakub Jelinek 2006-08-09 16:11:32 UTC
Can't reproduce with gcc-4.1.1-1.fc5 (FC5 updates gcc).


Note You need to log in before you can comment on or make changes to this bug.