Bug 200031 - authconfig missing /etc/pam.d/system-auth-ac, incorrect spec
authconfig missing /etc/pam.d/system-auth-ac, incorrect spec
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 17:55 EDT by Matt Domsch
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 06:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-07-24 17:55:17 EDT
Description of problem:
$ rpmlint authconfig-5.3.3-2.i386.rpm
W: authconfig no-url-tag
W: authconfig symlink-should-be-relative /usr/sbin/authconfig-tui
/usr/share/authconfig/authconfig-tui.py
W: authconfig symlink-should-be-relative /usr/sbin/authconfig
/usr/share/authconfig/authconfig.py
Traceback (most recent call last):
  File "/usr/share/rpmlint/rpmlint.py", line 250, in ?
    main()
  File "/usr/share/rpmlint/rpmlint.py", line 83, in main
    runChecks(pkg)
  File "/usr/share/rpmlint/rpmlint.py", line 138, in runChecks
    c.check(pkg)
  File "/usr/share/rpmlint/PamCheck.py", line 33, in check
    self.check_pam_file(pkg, dirname, i)
  File "/usr/share/rpmlint/PamCheck.py", line 36, in check_pam_file
    f = open(directory + filename)
IOError: [Errno 2] No such file or directory:
'/tmp/authconfig-5.3.3-2.i386.rpm.30511/etc/pam.d/system-auth-ac'


of course, that file doesn't exist if you 'rpm -qpil
authconfig-5.3.3-2.i386.rpm'.  So the spec file must say it exists, but then
it's not in the package.


Version-Release number of selected component (if applicable):
authconfig-5.3.3-2, fails on i386 and x86_64 same.
Comment 1 Tomas Mraz 2006-07-31 06:05:22 EDT
This is not a bug in authconfig - the file is generated when authconfig is run,
but it is owned by the package as %ghost.

Note You need to log in before you can comment on or make changes to this bug.