Bug 200047 - USB mass storage devices no longer automatically mount
USB mass storage devices no longer automatically mount
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 23:49 EDT by Paul Dickson
Modified: 2013-03-05 22:46 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.5.8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 19:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output info from udev and hald when mass-storage device is connected (36.08 KB, text/plain)
2006-08-05 16:03 EDT, Paul Dickson
no flags Details
Another output from udev and hald (34.86 KB, text/plain)
2006-09-03 10:17 EDT, Nickolay V. Shmyrev
no flags Details
gnome-volume-manager (5.48 KB, text/plain)
2006-09-03 10:36 EDT, Nickolay V. Shmyrev
no flags Details
hal patch (743 bytes, patch)
2006-09-11 23:55 EDT, eeyore
no flags Details | Diff

  None (edit)
Description Paul Dickson 2006-07-24 23:49:04 EDT
Description of problem:
If I attach my audio player (think USB thumb drive) or external HD, both USB
highspeed devices, they do not get mounted to /media/YEPP1 or /media/USBbackup
(respectively), nor anywhere else.


Version-Release number of selected component (if applicable):
gnome-volume-manager-1.5.15-4
gnome-mount-0.4-8
kernel-2.6.17-1.2358.fc6
kernel-2.6.17-1.2432.fc6
udev-095-3
dbus-0.90-8
dbus-devel-0.90-8
dbus-glib-0.70-4
dbus-glib-devel-0.70-4
dbus-python-0.70-5
dbus-sharp-0.63-4.fc6
dbus-x11-0.90-8
hal-0.5.7-13
hal-cups-utils-0.6.2-2
hal-devel-0.5.7-13
hal-gnome-0.5.7-13

How reproducible:
Always

Steps to Reproduce:
1. Connect the USB device.
2. Wait 5 to 10 second
3. Do "tail -n 25 /var/log/messages" to verify that udev created the device files.
  
Actual results:
The device files are created (/dev/sdb and /dev/sdb1), but sdb1 isn't mounted
and the mount point doesn't appear on the desktop.

Expected results:
The VFat file system on /dev/sdb1 should be mount as /media/$FSLABEL
(/media/YEPP1 or /media/USBBackup); and a mount point icon on the desktop appears.

Additional info:
A lot of packages have changed, but mostly for BuildRequires reasons.  This
might reach into HAL and DBUS.
Comment 1 Peter Robinson 2006-07-25 03:41:53 EDT
I'm seeing the same thing on a Centrino Core Duo notebook since FC6T1 too
(wasn't running FC on it prior to T1). USB Keys, USB HDDs, iPods etc are all
problematic but CDs automount just fine.

rpm -qa|grep -E 'gnome-mount|udev|kernel|gnome-volume-manager|hal|dbus'|sort
dbus-0.90-8
dbus-devel-0.90-8
dbus-glib-0.70-4
dbus-glib-devel-0.70-4
dbus-python-0.70-5
dbus-sharp-0.63-4.fc6
dbus-x11-0.90-8
gnome-mount-0.4-8
gnome-volume-manager-1.5.15-4
hal-0.5.7-13
hal-cups-utils-0.6.2-2
hal-devel-0.5.7-13
hal-gnome-0.5.7-13
kernel-2.6.17-1.2358.fc6
kernel-2.6.17-1.2432.fc6
udev-095-3
Comment 2 John (J5) Palmieri 2006-07-26 15:50:31 EDT
Fixed on devel and FC5
Comment 3 Paul Dickson 2006-07-28 11:04:02 EDT
Fixed is what version?

I running latest devel (rawhide) and it still doesn't work.
Comment 4 Paul Dickson 2006-07-28 11:06:12 EDT
I speek english good.  :-)

Fixed in what version?

I'm running the latest devel (rawhide) and it still doesn't work.

Comment 5 Paul Dickson 2006-07-28 11:32:38 EDT
Ah!  There's now an entry in /etc/udev/rules.d/ that refers to media.  There
were no entries here before.

I'm getting a "Too long line" error from 60-libsane.rules in the directory. 
Would this block the 90-hal.rules from loading?
Comment 6 John (J5) Palmieri 2006-07-28 11:33:55 EDT
hal-0.5.7.1-1.fc6.  You need to reboot after the update.
Comment 7 Paul Dickson 2006-07-28 12:05:50 EDT
I've already rebooted and I'm using hal-0.5.7.1-2.fc6 installed.

I'm going to try rebooting with sane-backends removed to avoid the error in #5
(Too long line) and see if it behaves better.
Comment 8 Paul Dickson 2006-07-28 12:29:40 EDT
Removing sane-backends did remove the error message but did not help the
situation.  My mass storage device still isn't being mounted.
Comment 9 Paul Dickson 2006-08-02 14:27:17 EDT
Earlier this morning my device wouldn't automount.  Then, after doing a yum
update, it now works.  I'm not sure what updated package resolved the problem.

The update was:
Installing:
 kernel                  i686       2.6.17-1.2505.fc6  development        16 M
 kernel-devel            i686       2.6.17-1.2505.fc6  development       4.4 M
Updating:
 ekiga                   i386       2.0.2-3          development       5.1 M
 gnupg                   i386       1.4.5-3          development       1.8 M
 hal-cups-utils          i386       0.6.2-3          development        26 k
 initscripts             i386       8.38-1           development       1.2 M
 irda-utils              i386       0.9.17-2.fc6     development        73 k
 java-1.4.2-gcj-compat   i386       1.4.2.0-40jpp_100rh  development        43 k
 kernel-doc              noarch     2.6.17-1.2505.fc6  development       2.7 M
 libselinux              i386       1.30.19-5        development        89 k
 libselinux-devel        i386       1.30.19-5        development       126 k
 libselinux-python       i386       1.30.19-5        development        50 k
 libtiff                 i386       3.8.2-5          development       312 k
 libtiff-devel           i386       3.8.2-5          development       492 k
 lvm2                    i386       2.02.06-3        development       1.0 M
 module-init-tools       i386       3.3-0.pre1.4.15  development       397 k
 perl-IO-Socket-SSL      noarch     0.994-1.fc6      development        47 k
 rhpxl                   i386       0.27-1           development        93 k
 selinux-policy          noarch     2.3.3-17         development       290 k
 selinux-policy-targeted  noarch     2.3.3-17         development       638 k
 xorg-x11-drv-ati        i386       6.6.1-6.fc6      development       333 k
Removing:
 kernel                  i686       2.6.17-1.2439.fc6  installed          44 M
 kernel-devel            i686       2.6.17-1.2439.fc6  installed          14 M

I have not rebooted in the past 5 days.
Comment 10 John (J5) Palmieri 2006-08-03 15:47:14 EDT
Most likely a library that was updated finally got loaded.  If you don't reboot
it is unknown when a new library will replace the older one in memory.
Comment 11 Paul Dickson 2006-08-05 15:09:39 EDT
I rebooted and it no longer works.

dbus-0.90-8
dbus-devel-0.90-8
dbus-glib-0.70-4
dbus-glib-devel-0.70-4
dbus-python-0.70-5
dbus-sharp-0.63-4.fc6
dbus-x11-0.90-8
gnome-mount-0.4.0.2006.07.24-1.fc6
gnome-volume-manager-2.15.0-1.fc6
hal-0.5.7.1-2.fc6
hal-cups-utils-0.6.2-3
hal-devel-0.5.7.1-2.fc6
hal-gnome-0.5.7.1-2.fc6
kernel-2.6.17-1.2488.fc6
kernel-2.6.17-1.2505.fc6
kernel-2.6.17-1.2510.fc6
kernel-2.6.17-1.2527.fc6
kernel-devel-2.6.17-1.2488.fc6
kernel-devel-2.6.17-1.2505.fc6
kernel-devel-2.6.17-1.2510.fc6
kernel-devel-2.6.17-1.2527.fc6
kernel-doc-2.6.17-1.2527.fc6
udev-095-3

running:  kernel-2.6.17-1.2527.fc6
Comment 12 Paul Dickson 2006-08-05 16:03:38 EDT
Created attachment 133697 [details]
Output info from udev and hald when mass-storage device is connected

I did a "udevcontrol log_priority=info" and added the arguments "--daemon=yes
--verbose=yes --use-syslog" to hald in /etc/rc.d/init.d/haldaemon.

The attachment is the results found in /var/log/messages.

The results are hard for me to intrepret (and I'm likely wrong), but I think
the problem might be something higher on the food chain.
Comment 13 Paul Dickson 2006-08-05 19:08:25 EDT
Reverting back to gnome-volume-manager-1.5.15-4 allowed auto mounting to work.

Reverting gnome-session-2.15.4-2 allowed gnome-volume-manager to be started at
the beginning of my gnome session.

Comment 14 Nickolay V. Shmyrev 2006-09-03 09:48:17 EDT
It's really a problem to me. I have to reboot after every suspend since USB
stick is not mounted anymore.

PM: Adding info for No Bus:target2:0:1
PM: Removing info for No Bus:target2:0:1
PM: Adding info for No Bus:target2:0:2
PM: Removing info for No Bus:target2:0:2
PM: Adding info for No Bus:target2:0:3
PM: Removing info for No Bus:target2:0:3
PM: Adding info for No Bus:target2:0:4
PM: Removing info for No Bus:target2:0:4
PM: Adding info for No Bus:target2:0:5
PM: Removing info for No Bus:target2:0:5
PM: Adding info for No Bus:target2:0:6
PM: Removing info for No Bus:target2:0:6
PM: Adding info for No Bus:target2:0:7
PM: Removing info for No Bus:target2:0:7
Comment 15 Nickolay V. Shmyrev 2006-09-03 10:17:01 EDT
Created attachment 135458 [details]
Another output from udev and hald
Comment 16 Nickolay V. Shmyrev 2006-09-03 10:36:07 EDT
Created attachment 135459 [details]
gnome-volume-manager

First time device was mounted successfully, second time mount failed.
Comment 17 Nickolay V. Shmyrev 2006-09-03 12:08:29 EDT
I think this info is relevant

 [I] osspec.c:232: SEQNUM=1496, ACTION=add, SUBSYSTEM=block, DEVPATH=/sys/block/
 [I] hotplug.c:181: /sys/block/sda/sda1 is a block device (subsystem)
 [I] blockdev.c:637: block_add: sysfs_path=/sys/block/sda/sda1 dev=/dev/sda1 is_
   [I] blockdev.c:547: get_luks_uuid: device_file=/dev/sda1
 [I] blockdev.c:673: Ignoring hotplug event - no parent
 [W] blockdev.c:1043: Not adding device object


Comment 18 Nickolay V. Shmyrev 2006-09-03 13:52:15 EDT
More investigation: Parent device isn't created because it's scsi.type is
"unknown". That's all because it seems that /sys/block/sda/device/type is
created with delay.

Sep  3 21:41:53 gnome udevd-event[24843]: run_program: '/lib/udev/udev_run_hotplugd'
Sep  3 21:41:53 gnome hald[24053]: 21:41:53.308 [E] util.c:463: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-4/4-4:1.0/host5/target5:0:0/5:0:0:0/model'
Sep  3 21:41:53 gnome udevd-event[24843]: run_program:
'/lib/udev/udev_run_hotplugd' returned with status 0
Sep  3 21:41:53 gnome hald[24053]: 21:41:53.314 [E] util.c:463: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-4/4-4:1.0/host5/target5:0:0/5:0:0:0/vendor'
Sep  3 21:41:53 gnome udevd-event[24843]: run_program: '/lib/udev/udev_run_devd'
Sep  3 21:41:53 gnome hald[24053]: 21:41:53.317 [E] util.c:322: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-4/4-4:1.0/host5/target5:0:0/5:0:0:0/type'
Sep  3 21:41:53 gnome hald[24053]: 21:41:53.320 [W] physdev.c:686: scsi.type is
-1081266392
Comment 20 Nickolay V. Shmyrev 2006-09-03 17:35:32 EDT
Actually it's udev bug 201422 and it should be resolved in latest rawhide please
mark as a duplicate
Comment 21 eeyore 2006-09-11 23:55:29 EDT
Created attachment 136051 [details]
hal patch
Comment 22 eeyore 2006-09-12 00:02:06 EDT
Sorry never used this before :)
Above patch was made by Martin Pitti from ubuntu edgy patch lists. I've been
having problems with all usb attached devices since FC5 upgrade to hal-0.5.7.1
rebuilt rpm with patch above and my drives show up again.  Hope this helps
Comment 23 David Zeuthen 2006-09-28 19:25:31 EDT
Should be fixed with hal 0.5.8.1 in latest rawhide otherwise please reopen.

Note You need to log in before you can comment on or make changes to this bug.