Bug 200048 - gdb crashes on ^X 1
gdb crashes on ^X 1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Oliva
:
: 195895 (view as bug list)
Depends On:
Blocks: 195895 202345 202346 202347
  Show dependency treegraph
 
Reported: 2006-07-25 00:02 EDT by mmiikkee13
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gdb-6.5-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 10:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb.log (generated it with 'gdb 2>&1 |tee gdb.log') (4.52 KB, text/plain)
2006-07-25 00:02 EDT, mmiikkee13
no flags Details
gdb-6.5 patch fixing the memory corruption (1010 bytes, patch)
2006-08-13 05:31 EDT, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description mmiikkee13 2006-07-25 00:02:12 EDT
Description of problem:
gdb crashes when I hit ^X and then 1 (which should bring up a nice ncurses
window with a view of the source code.) gnome-terminal refused to scroll up, but
here's what I got from the crash: http://rafb.net/paste/results/UjscKr81.html

Version-Release number of selected component (if applicable):
gdb.i386                                 6.3.0.0-1.122          installed

How reproducible:
[mike in ~]$ gdb
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
Copyright 2004 Free Software Foundation, Inc.
(blah blah blah, legal stuff)
(gdb) (hit ctrl-X, release both, press 1 (one))
  
Actual results:
A major crash, http://rafb.net/paste/results/UjscKr81.html
I also tried tee'ing it to a log file, but it's mostly unreadable to me. I
attached it in case someone here is well-versed in escape codes ;-)

Expected results:
A nice ncurses window with an interactive view of the source code.
Comment 1 mmiikkee13 2006-07-25 00:02:12 EDT
Created attachment 132959 [details]
gdb.log (generated it with 'gdb 2>&1 |tee gdb.log')
Comment 2 Jan Kratochvil 2006-08-13 05:31:35 EDT
Created attachment 134094 [details]
gdb-6.5 patch fixing the memory corruption

Thanks for this bugreport.
Provided only the RawHide/FC6 version here - binary built for FC5.
http://www.jankratochvil.net/priv/pr200048/
Comment 6 Alexandre Oliva 2006-08-24 03:09:43 EDT
*** Bug 195895 has been marked as a duplicate of this bug. ***
Comment 7 Alexandre Oliva 2006-08-24 03:16:09 EDT
gdb-6.5-5 in today's rawhide should have the fix.

Note You need to log in before you can comment on or make changes to this bug.