This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 200065 - Update qemu to 0.8.2
Update qemu to 0.8.2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 05:38 EDT by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 05:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-07-25 05:38:29 EDT
Qemu 0.8.2 has been released a few days ago. I've made a local build :
- Had to remove Patch2 (fixes got merged it seems)
- Had to add "texi2html" build requirement or *.html doc files weren't built

Addingg the texi2html build requirement also made the man pages build and
install, which seems like a good thing. So the %{_mandir}... line will need to
be uncommented from %files. Other than that, it builds and runs fine for me
(x86_64).
Comment 1 Matthias Saou 2006-08-23 10:59:12 EDT
ping? This is really a trivial update. Please just let me know if you want me to
take care of it.
Comment 2 David Woodhouse 2006-08-23 11:25:25 EDT
Feel free; thanks for offering.
Comment 3 Matthias Saou 2006-08-24 05:07:13 EDT
Done, 0.8.2 will be available for devel after the next push. It wasn't that
easy, though, since I was testing on RHEL4 x86_64, and ran into quite a few
differences on devel, then ppc specific :-)

If you had a minute to double check all the changes just to make sure, it would
be great. Here is the rpm %changelog entry :

* Wed Aug 23 2006 Matthias Saou <http://freshrpms.net/> 0.8.2-1
- Update to 0.8.2 (#200065).
- Drop upstreamed syscall-macros patch2.
- Put correct scriplet dependencies.
- Force install mode for the init script to avoid umask problems.
- Add %postun condrestart for changes to the init script to be applied if any.
- Update description with the latest "about" from the web page (more current).
- Update URL to qemu.org one like the Source.
- Add which build requirement.
- Don't include texi files in %doc since we ship them in html.
- Switch to using gcc34 on devel, FC5 still has gcc32.
- Add kernheaders patch to fix linux/compiler.h inclusion.
- Add target-sparc patch to fix compiling on ppc (some int32 to float).
Comment 4 David Woodhouse 2006-08-24 06:00:37 EDT
Heh. Welcome to my pain. Since you have access to x86_64, were you able to
confirm that we still need to disable the sparc targets? It'd be good if we
could build those on x86_64 again.
Comment 5 David Woodhouse 2006-08-24 07:00:51 EDT
All looks good to me, and seems to work on PPC. Thanks. 

Did you send the patches upstream?
Comment 6 Matthias Saou 2006-08-24 07:20:58 EDT
Removing the x86_64 specific target list passed to configure makes the package
still build on FC devel x86_64, so I'll push a second release with that change.

I didn't send the patches upstream. Feel free to do so (I'm not on any list),
but otherwise I can do it. FYI :
- The first patch is needed because linux/compiler.h is no longer present in FC6
  glibc-kernheader, and from what I've found, that include shouldn't be needed.
- The second patch seems to only affect ppc (the transformations are only needed
  there it seems), and seem like a simple oversight after changes to the params.
Comment 7 Matthias Saou 2006-08-24 07:43:29 EDT
* Thu Aug 24 2006 Matthias Saou <http://freshrpms.net/> 0.8.2-2
- Remove the target-list iteration for x86_64 since they all build again.
- Make gcc32 vs. gcc34 conditional on %{fedora} to share the same spec for
  FC5 and FC6.

That second change makes backporting this new package to FC-5 trivial, as
everything can be kept identical.

Note You need to log in before you can comment on or make changes to this bug.