Bug 200100 - Since kernel 2.6.17 VT console is broken under non-UTF8 locales
Since kernel 2.6.17 VT console is broken under non-UTF8 locales
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 10:28 EDT by Dmitry Butskoy
Modified: 2014-03-16 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 12:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to handle non-utf locales (1.10 KB, patch)
2006-07-25 10:31 EDT, Dmitry Butskoy
no flags Details | Diff
/etc/profile.d script to solve this issue (224 bytes, text/plain)
2006-08-11 09:52 EDT, Dmitry Butskoy
no flags Details

  None (edit)
Description Dmitry Butskoy 2006-07-25 10:28:27 EDT
Description of problem:
Since the version 2.6.17, the linux kernel uses utf8 for vt consoles by default.

For utf8 console support under the kernels <= 2.6.16, /bin/unicode_start script
is used (invoked by /sbin/setsysfont and by /etc/profile.d/lang.sh). There was
no special things for support non-utf8 console locales, as these kernels did not
use utf8 by default.

Since Fedora has update the kernel to 2.6.17 line, the non-utf users see an
unexpected changes in their consoles when invoke any screen (curses/slang)
applications, or type/read non-ascii text. (BTW it is much enough worries them).

To handle non-utf8 console locales under kernels >= 2.6.17, some simple patch is
needed for /etc/profile.d/lang.{sh|csh} (see below).


Steps to Reproduce:

Set any non-UTF8 locale in LANG in /etc/sysconfig/i18n and reboot your 2.6.17
kernel.
  
Run some screen application, for example "ntsysv". The console screen looks ugly.
Run "unicode_stop", then run the application again. All looks OK.


Additional info:

Certainly non-UTF locales are obsolete things, but some people still use it. As
there is no too much work to continue to support such locales, these locales
should be supported.
Anyway, dropping some of the locales must take place between whole FC releases
(FC5->FC6 etc.), not just by the ordinary update (2.6.16->2.6.17) during the
particular FC life cycle.
Comment 1 Dmitry Butskoy 2006-07-25 10:31:37 EDT
Created attachment 132987 [details]
Patch to handle non-utf locales

It is against initscripts-8.31.5, but IMHO is applicable for rawhide's
initscripts-8.36 too.

IMO nothing is spoiled for kernel < 2.6.16.
Comment 2 Dmitry Butskoy 2006-08-11 09:52:19 EDT
Created attachment 134019 [details]
/etc/profile.d script to solve this issue

AN alternate way (no patching needed). Just place this file under
/etc/profile.d
and make sure it is executable.

Can be used by those who comes here and does not want to wait for an updated
version...
Comment 3 Bill Nottingham 2006-10-05 12:48:54 EDT
Fixed in 8.44-1.
Comment 4 Fedora Update System 2006-10-19 17:16:05 EDT
initscripts-8.31.6-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Rudolf Ulc 2006-10-23 05:24:05 EDT
*** Bug 197604 has been marked as a duplicate of this bug. ***
Comment 6 Dmitry Butskoy 2006-10-23 07:06:28 EDT
Ack for FC5. Thanks.
Comment 7 Fedora Update System 2006-10-26 13:45:06 EDT
initscripts-8.31.6-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.