Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 200126 - x86_64 guest creation fails
x86_64 guest creation fails
Status: CLOSED DUPLICATE of bug 200004
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks: 200124
  Show dependency treegraph
 
Reported: 2006-07-25 12:32 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 15:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-07-25 12:32:20 EDT
With all 2.6.18-rc based Xen kernels, guest creation fails.  As opposed to the
error on x86, the page table setup succeeds and then the guest crashses.

This occurs for both PV and FV guests.  The crash trace from a FV guest is:
(XEN) Can not get io request shared page from E820 memory map for HVM
domain.
(XEN) domain_crash_sync called from hvm.c:111
(XEN) Domain 1 (vcpu#0) crashed on cpu#1:
(XEN) ----[ Xen-3.0-unstable    Not tainted ]----
(XEN) CPU:    1
(XEN) RIP:    0010:[<0000000000100000>]
(XEN) RFLAGS: 0000000000000002   CONTEXT: hvm
(XEN) rax: 0000000000000000   rbx: 0000000000000000   rcx:
0000000000000000
(XEN) rdx: 0000000000000000   rsi: 0000000000000000   rdi:
0000000000000000
(XEN) rbp: 0000000000000000   rsp: 0000000000000000   r8:
0000000000000000
(XEN) r9:  0000000000000000   r10: 0000000000000000   r11:
0000000000000000
(XEN) r12: 0000000000000000   r13: 0000000000000000   r14:
0000000000000000
(XEN) r15: 0000000000000000   cr0: 0000000000000000   cr3:
0000000000000000
(XEN) ds: 0008   es: 0008   fs: 0008   gs: 0008   ss: 0008   cs: 0010
Comment 1 Jason Baron 2006-07-25 13:38:52 EDT
i'm also hitting this on 2.6.17-1.2439.fc6xen, when i do:
/usr/sbin/xenguest-install.py 

What is the name of your virtual machine? foo
 How much RAM should be allocated (in megabytes)? 256
 What would you like to use as the disk (path)? /tmp/xen-image
 What is the install location?
nfs:qafiler.boston.redhat.com:/vol/vol1/redhat/fc5-x86_64


Starting install...
Communication error with proxy: got 8250 bytes packet
libvir: Xen Daemon error : GET operation failed: No such domain foo
Traceback (most recent call last):
  File "/usr/sbin/xenguest-install.py", line 475, in ?
    main()
  File "/usr/sbin/xenguest-install.py", line 466, in main
    start_paravirt_install(name, ram, disk, mac, uuid, bridge, src, options.extra)
  File "/usr/sbin/xenguest-install.py", line 343, in start_paravirt_install
    dom = conn.createLinux(cfgxml, 0)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 233, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed')
libvirt.libvirtError: virDomainCreateLinux() failed

The output of 'xm dmesg' is:

(XEN) domain_crash_sync called from entry.S
(XEN) Domain 11 (vcpu#0) crashed on cpu#3:
(XEN) ----[ Xen-3.0-unstable    Not tainted ]----
(XEN) CPU:    3
(XEN) RIP:    e033:[<ffffffff80100000>]
(XEN) RFLAGS: 0000000000010202   CONTEXT: guest
(XEN) rax: 0000000000000000   rbx: 0000000000000000   rcx: 0000000000000000
(XEN) rdx: 0000000000000000   rsi: ffffffff807d1000   rdi: 0000000000000000
(XEN) rbp: 0000000000000000   rsp: ffffffff807de000   r8:  0000000000000000
(XEN) r9:  0000000000000000   r10: 0000000000000000   r11: 0000000000000000
(XEN) r12: 0000000000000000   r13: 0000000000000000   r14: 0000000000000000
(XEN) r15: 0000000000000000   cr0: 000000008005003b   cr3: 0000000035d8b000
(XEN) ds: 0000   es: 0000   fs: 0000   gs: 0000   ss: e02b   cs: e033
(XEN) Guest stack trace from rsp=ffffffff807de000:
(XEN)   Fault while accessing guest memory.

Comment 2 Jeremy Katz 2006-07-26 15:28:49 EDT

*** This bug has been marked as a duplicate of 200004 ***

Note You need to log in before you can comment on or make changes to this bug.