Bug 200143 - Useless Info line in /etc/cups/printers.conf
Useless Info line in /etc/cups/printers.conf
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 200144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 14:00 EDT by Brian Smith
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 06:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Smith 2006-07-25 14:00:56 EDT
Description of problem:

I would like a way in the export xml file, or in the printconf dialog, to set 
the description of the printer.

In /etc/cups/printers.conf the Info line is always 'Created by redhat-config-
printer 0.6.x' which is useless to my MacOX X users who print through my 
system.  I can edit the printers.conf, but of course that is recreated each 
restart of cups.

Please, is there a keyword I can place in my xml file, which is imported by 
printconf-tui --Ximport, that will set this line to something useful?
Comment 1 Tim Waugh 2006-07-26 04:41:10 EDT
*** Bug 200144 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2006-07-26 13:01:16 EDT
Unfortunately not. :-(

This is a limitation of the redhat-config-printer application, and will be
addressed in Red Hat Enterprise Linux 5 by eliminating the XML step altogether
and having the printer configuration tool communicate with CUPS directly.
Comment 3 Brian Smith 2006-07-26 13:06:56 EDT
Ok, great!  I assume there will still be a way of saving the config and reimport
for fast system restore.

Oh, and sorry for the double post bugzilla gave me an error that 'product did
not exist' and I thought it had failed.

Note You need to log in before you can comment on or make changes to this bug.