Bug 200150 - gcc 4.1.1 linker very slow
gcc 4.1.1 linker very slow
Status: CLOSED DUPLICATE of bug 198254
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 14:42 EDT by Matt Ginsberg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 04:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Ginsberg 2006-07-25 14:42:50 EDT
Description of problem:

Seems to be a symbol table issue.  Linker proceeds at normal speed if linking
binaries compiled with 4.0 from FC4 (this is reported by others; I haven't
verified it).  Linker proceeds at normal speed if I use the -s switch.  So it
eems that the 4.1.1 compiler is generating symbol tables that the 4.1.1 linker
is having difficulty processing.  I'm seeing a 10x-20x slowdown in linking speeds.


Version-Release number of selected component (if applicable): 4.1.1


How reproducible: totally


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-08-03 04:37:12 EDT

*** This bug has been marked as a duplicate of 198254 ***

Note You need to log in before you can comment on or make changes to this bug.