Bug 200150 - gcc 4.1.1 linker very slow
Summary: gcc 4.1.1 linker very slow
Status: CLOSED DUPLICATE of bug 198254
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-25 18:42 UTC by Matt Ginsberg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 08:37:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Ginsberg 2006-07-25 18:42:50 UTC
Description of problem:

Seems to be a symbol table issue.  Linker proceeds at normal speed if linking
binaries compiled with 4.0 from FC4 (this is reported by others; I haven't
verified it).  Linker proceeds at normal speed if I use the -s switch.  So it
eems that the 4.1.1 compiler is generating symbol tables that the 4.1.1 linker
is having difficulty processing.  I'm seeing a 10x-20x slowdown in linking speeds.


Version-Release number of selected component (if applicable): 4.1.1


How reproducible: totally


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2006-08-03 08:37:12 UTC

*** This bug has been marked as a duplicate of 198254 ***


Note You need to log in before you can comment on or make changes to this bug.