Bug 200179 - new freetype causes gaim to crash on mousing over URLs (tooltip)
new freetype causes gaim to crash on mousing over URLs (tooltip)
Status: CLOSED DUPLICATE of bug 200033
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: freetype (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
:
: 200130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-25 17:55 EDT by Eric Eisenhart
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 13:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Eisenhart 2006-07-25 17:55:30 EDT
Description of problem:
gaim crashes with a "Floating point exception" when mousing over URLs in
chatrooms.  Appears to be a problem with freetype font handling and not a
problem in gaim itself

Version-Release number of selected component (if applicable):
gaim-1.5.0-12.el4
freetype-2.1.9-1.rhel4.4


How reproducible:
Talk to somebody, say a URL, then hover the mouse over the URL.  Normally a
tooltip appears, but when those versions are installed it simply crashes
instead.  Downgrading freetype fixes the problem.

Steps to Reproduce:
1. Install gaim and freetype-2.1.9-1.rhel4.4
2. Connect to a network (tested with AIM and Jabber)
3. IM somebody or join a chatroom
4. Say http://bugzilla.redhat.com/
5. hover the mouse over the URL
  
Actual results:
crash with "Floating point exception"

Expected results:
a tool tip (small borderless popup) with the URL in it

Additional info:
Did an strace, here's the end:
access("/usr/lib/pango/1.4.0/modules/pango-hangul-fc.so", F_OK) = 0
open("/usr/lib/pango/1.4.0/modules/pango-hangul-fc.so", O_RDONLY) = 45
read(45, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\244\t\0"..., 512) = 512
fstat64(45, {st_mode=S_IFREG|0755, st_size=9256, ...}) = 0
old_mmap(NULL, 12132, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 45, 0) =
0xe74000
old_mmap(0xe76000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 45, 0x1000) = 0xe76000
close(45)                               = 0
open("/usr/share/fonts/bitmap-fonts/9x15.pcf", O_RDONLY) = 45
fcntl64(45, F_SETFD, FD_CLOEXEC)        = 0
fstat64(45, {st_mode=S_IFREG|0644, st_size=565716, ...}) = 0
mmap2(NULL, 565716, PROT_READ, MAP_PRIVATE, 45, 0) = 0xb4dcd000
close(45)                               = 0
brk(0xa307000)                          = 0xa307000
mmap2(NULL, 528384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb4d4c000
munmap(0xb4d4c000, 528384)              = 0
--- SIGFPE (Floating point exception) @ 0 (0) ---
+++ killed by SIGFPE +++
Process 31472 detached
Comment 2 Ray Strode [halfline] 2006-07-27 13:44:28 EDT

*** This bug has been marked as a duplicate of 200033 ***
Comment 3 Ngo Than 2006-07-27 15:59:42 EDT
*** Bug 200130 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.