Bug 200190 - No sound from Intel 82801g - kernel 2.6.17.x smp
Summary: No sound from Intel 82801g - kernel 2.6.17.x smp
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-26 00:32 UTC by Chris Mohler
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 20:55:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from system-config-soundcard (7.79 KB, text/plain)
2006-07-26 00:32 UTC, Chris Mohler
no flags Details
dmesg output from 2.6.16 kernel (21.15 KB, application/octet-stream)
2006-07-26 00:33 UTC, Chris Mohler
no flags Details
dmesg output from 2.7.16 kernel (51.37 KB, application/octet-stream)
2006-07-26 00:34 UTC, Chris Mohler
no flags Details

Description Chris Mohler 2006-07-26 00:32:29 UTC
Description of problem:
No sound from onboard intel controller whenn booting from 2.6.17.x .  Sound
works correctly in 2.6.16.x kernels.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.17-1.2157_FC5 (doesn't work)
kernel-smp-2.6.16-1.2133_FC5 (works)

How reproducible:
Seems to be every time.

Steps to Reproduce:
1. Boot from 2.16.7.x smp kernel
2. Run system-config-soundcard as root
  
Actual results:
Sound device detected correctly, but no sound.

Expected results:
Sound device detected, and it plays sound...

Additional info:
Forgive me if this is a duplicate.  I saw one bug similar to this, but no
mention of the kernel and it was filed against alsa-lib:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187906

This happens with all of the 2.6.17 smp kernels I've tried so far.

I'm attaching the log from system-config-soundcard under 2.6.17 and the dmesg
output from 2.6.16 and 2.6.17.

HTH,
Chris

Comment 1 Chris Mohler 2006-07-26 00:32:29 UTC
Created attachment 133034 [details]
log from system-config-soundcard

Comment 2 Chris Mohler 2006-07-26 00:33:42 UTC
Created attachment 133035 [details]
dmesg output from 2.6.16 kernel

Comment 3 Chris Mohler 2006-07-26 00:34:49 UTC
Created attachment 133036 [details]
dmesg output from 2.7.16 kernel

Comment 4 Chris Mohler 2006-09-03 20:55:55 UTC
This problem went away in:
2.6.17-1.2174_FC5smp

Chris


Note You need to log in before you can comment on or make changes to this bug.