This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 200204 - strange error message
strange error message
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sturmbahnfahrer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 02:57 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-18 15:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot exposing the "sparkling" (257.24 KB, image/png)
2006-07-26 04:13 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Ralf Corsepius 2006-07-26 02:57:42 EDT
Description of problem:
Another aspect having been mentioned during the review, in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199310#c10


Running it issues this error message:
...
Your plib (version 1.8.4) has a bug in the 3ds loader. Workaround enabled.
Underrrun!
..

In https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199310#c11
you had replied:

> Hmm, besides that does it work?
Well, it doesn't segfault, and doesn't expose issue which would qualify it as
unusable.

I am hearing sound drop-outs, and am observing some kind of "sparkling".
Hard to describe, may-be "32bit wide and 1bit high white bit blob random noise"
desturbing the display matches.

Version-Release number of selected component (if applicable):
sturmbahnfahrer-1.1-2.fc5

How reproducible:
Almost deterministic.

Steps to Reproduce:
1. run sturmbahnfahrer
2. play
3. exit
  
Actual results:
see above.
Comment 1 Hans de Goede 2006-07-26 03:26:56 EDT
I've had some sound issues myself during packaging, with which upstream has been
very helpfull and lead to the release of the 1.1 version (I started with
packaging the 1.0 version). Unfortunatly I cannot reproduce those you're
experiencing now.

I've requested upstream to contact you (preferably through this BZ ticket) and
try to work things out with you. Sofar upstream has been very responsive.

Comment 2 Ralf Corsepius 2006-07-26 04:13:46 EDT
Created attachment 133052 [details]
Screenshot exposing the "sparkling"

Note the "bright" (white?) artefacts near to the end of the "board".

Apparently, unlike previously stated, they aren't fixed width.

The wander accross the screen, always near to edges (e.g. along the edges of
the board) or near to animated elements (e.g. below the clock), whenever the
image changes/is moving.

To me they look like rendering artefacts.
Comment 3 Bram Stolk 2006-07-26 12:44:50 EDT
The plib workaround message is harmless.

The sound drop outs can occur if the host machine is too slow.
Can you describe your hardware? CPU? MHz? graphics card?

The visual artefacts are puzzling. I cannot explain those. Could
it be hardware failure? Do other 3D apps run fine without visual
noise?

I noticed that on your screenshot, your fps is 3. Is this a 
bogus measurement due to the screen grabbing that occurred?
Or is your framerate during play actually 3 fps?

In the latter case:
Frequent sound drop outs are to be expected.
The sound drop outs can in this case be avoided by increasing the
framelag argument of SoundEngineAlsa. Edit main.cxx at line 651
and double the 5000 value.
However: a higher nr will delay the sounds somewhat wrt visual
cues. Also, 3 fps is not really playable, so it may be in vain
to increase this val.

  Bram
Comment 4 Ralf Corsepius 2006-07-26 17:18:07 EDT
(In reply to comment #3)
> The plib workaround message is harmless.
> 
> The sound drop outs can occur if the host machine is too slow.
> Can you describe your hardware? CPU? MHz? graphics card?
It's an older 1GHz Intel P4, w/ a GeForce4 MX 4000 (Using kmod-nvidia)

> The visual artefacts are puzzling. I cannot explain those. Could
> it be hardware failure? Do other 3D apps run fine without visual
> noise?
Well, normally yes. I am using this machine for 3D application development
myself and so far haven't noticed such artefacts in other applications.

> I noticed that on your screenshot, your fps is 3. Is this a 
> bogus measurement due to the screen grabbing that occurred?
Probably. The normal framerate with sturmbahnfahrer is, depending on the
complexity of the scene, somewhere in the 25-35fps range, typically near 30fps.
Comment 5 Hans de Goede 2006-09-25 05:49:52 EDT
Bram, Any progress on this?
Comment 6 Bram Stolk 2006-09-25 07:03:05 EDT
Graphics artefacts have not been reproducable.
About the sound: the reporter could try increasing the '5000' value
I recommended earlier.
Comment 7 Hans de Goede 2006-10-05 05:16:08 EDT
Changing status to assigned, as this is not really new any more.
Comment 8 Hans de Goede 2006-11-19 02:15:45 EST
Ralf could you please try increasing the '5000' value as recomended in an
earlier comment? And then report back with the results?
Comment 9 Hans de Goede 2007-03-18 15:24:42 EDT
Closing due to lack of response from reporter.

Note You need to log in before you can comment on or make changes to this bug.