Bug 2002095 - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
Summary: nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-07 22:50 UTC by Matt Fagnani
Modified: 2021-09-30 00:52 UTC (History)
7 users (show)

Fixed In Version: nodejs-16.10.0-1.fc35
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-30 00:52:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Fagnani 2021-09-07 22:50:45 UTC
Description of problem:

I ran sudo dnf offline-upgrade download with updates-testing enabled in a Fedora 35 KDE Plasma installation with nodejs-1:16.5.0-2.fc35 and libuv-1:1.41.1-2.fc35 installed. dnf errors indicated that nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64.

Problem 1: cannot install the best update candidate for package nodejs-1:16.5.0-2.fc35.x86_64
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
 Problem 2: package nodejs-full-i18n-1:16.8.0-1.fc35.x86_64 requires nodejs(x86-64) = 1:16.8.0-1.fc35, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-full-i18n-1:16.5.0-2.fc35.x86_64
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
 Problem 3: package npm-1:7.21.0-1.16.8.0.1.fc35.x86_64 requires nodejs = 1:16.8.0-1.fc35, but none of the providers can be installed
  - cannot install the best update candidate for package npm-1:7.19.1-1.16.5.0.2.fc35.x86_64
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.i686
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
 Problem 4: problem with installed package nodejs-1:16.5.0-2.fc35.x86_64
  - package nodejs-docs-1:16.8.0-1.fc35.noarch conflicts with nodejs < 1:16.8.0-1.fc35 provided by nodejs-1:16.5.0-2.fc35.x86_64
  - cannot install the best update candidate for package nodejs-docs-1:16.5.0-2.fc35.noarch
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
 Problem 5: problem with installed package nodejs-full-i18n-1:16.5.0-2.fc35.x86_64
  - package nodejs-full-i18n-1:16.5.0-2.fc35.x86_64 requires nodejs(x86-64) = 1:16.5.0-2.fc35, but none of the providers can be installed
  - package nodejs-1:16.5.0-2.fc35.x86_64 requires nodejs-libs(x86-64) = 1:16.5.0-2.fc35, but none of the providers can be installed
  - cannot install both nodejs-libs-1:16.8.0-1.fc35.x86_64 and nodejs-libs-1:16.5.0-2.fc35.x86_64
  - package nodejs-full-i18n-1:16.8.0-1.fc35.x86_64 requires nodejs(x86-64) = 1:16.8.0-1.fc35, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-libs-1:16.5.0-2.fc35.x86_64
  - nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64
...
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nodejs-docs                                noarch  1:16.8.0-1.fc35            updates-testing  6.4 M
 nodejs-libs                                x86_64  1:16.8.0-1.fc35            updates-testing   14 M
Skipping packages with broken dependencies:
 nodejs                                     i686    1:16.8.0-1.fc35            updates-testing   95 k
 nodejs                                     x86_64  1:16.8.0-1.fc35            updates-testing   95 k
 nodejs-full-i18n                           x86_64  1:16.8.0-1.fc35            updates-testing  7.8 M
 npm                                        x86_64  1:7.21.0-1.16.8.0.1.fc35   updates-testing  2.2 M

Transaction Summary
======================================================================================================
Upgrade  29 Packages
Skip      6 Packages

Version-Release number of selected component (if applicable):
libuv-1.42.0-2.fc35
nodejs-1:16.8.0-1.fc35.x86_64

How reproducible:
2/2 times

Steps to Reproduce:
1. boot a Fedora 35 KDE Plasma installation with nodejs-1:16.5.0-2.fc35 and libuv-1:1.41.1-2.fc35 installed
2. log in to Plasma on Wayland
3. start konsole
4. sudo dnf offline-upgrade download or sudo dnf upgrade --refresh with updates-testing enabled

Actual results:
dnf errors due to "nothing provides libuv >= 1:1.42.0 needed by nodejs-1:16.8.0-1.fc35.x86_64"

Expected results:
No errors would happen.

Additional info:
I updated to libuv-1.42.0-2.fc35 from https://koji.fedoraproject.org/koji/buildinfo?buildID=1827408 I updated nodejs without errors after that.
The nodejs update at https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5 might need libuv-1.42.0-2.fc35 to be added to it.

Comment 1 Fedora Update System 2021-09-08 12:13:21 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 2 Fedora Update System 2021-09-08 18:46:56 UTC
FEDORA-2021-5ca1a838f5 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5ca1a838f5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-09-14 20:41:07 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 4 Fedora Update System 2021-09-16 16:59:57 UTC
FEDORA-2021-5ca1a838f5 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5ca1a838f5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-09-27 12:20:00 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 6 Fedora Update System 2021-09-28 20:20:14 UTC
FEDORA-2021-4dd44521bf has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4dd44521bf

Comment 7 Gaban 2021-09-29 00:28:50 UTC
I'm having a similar issue with Fedora 35. Log below:

Erro: 
 Problema: solicitações conflitantes
  - pacote nodejs-1:16.9.1-4.fc35.i686 requer libuv >= 1:1.42.0, mas nenhum dos provedores pode ser instalado
  - pacote nodejs-1:16.9.1-4.fc35.x86_64 requer libuv >= 1:1.42.0, mas nenhum dos provedores pode ser instalado
  - package libuv-1:1.42.0-2.module_f35+12821+0ca3efb5.x86_64 is filtered out by modular filtering
  - package libuv-1:1.42.0-2.module_f35+12941+0548739f.x86_64 is filtered out by modular filtering
(tente adicionar '--skip-broken' para pular pacotes desinstaláveis)

Comment 8 Gaban 2021-09-29 00:35:12 UTC
I forgot to mention. I didn't have neither nodejs nor libuv installed previously on fedora 34.

Comment 9 Fedora Update System 2021-09-29 02:11:10 UTC
FEDORA-2021-4dd44521bf has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4dd44521bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4dd44521bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-09-30 00:52:55 UTC
FEDORA-2021-4dd44521bf has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.