Bug 20026 - SMP problems w/ old initscripts + errata kernel (no /boot/kernel.h)
Summary: SMP problems w/ old initscripts + errata kernel (no /boot/kernel.h)
Status: CLOSED DUPLICATE of bug 20025
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-30 10:58 UTC by Pekka Savola
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 10:58:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-10-30 10:58:13 UTC
I've been plagued by this one problem for a long time now.  As it came
across today, I pinpointed it.

If you're using a new kernel (errata 2.2.16-3, ext2 2.2.17-5) on older
system (RH60), compiling SMP modules (e.g. external network
drivers from ftp.scyld.com) will fail because SMP related issues are not
defined and modules are compiled for UP.  Manually defining -D__SMP__ or
friends won't help either because other stuff is left out too.

This is caused by the fact that those errata kernels don't
Require: initscripts new enough which create /boot/kernel.h at boot.

Updated initscripts would be probably too much to ask, but _please_ at
least 
Require: decent initscript versions :-)

Comment 1 Daniel Roesen 2000-10-31 13:37:48 UTC

*** This bug has been marked as a duplicate of 20025 ***


Note You need to log in before you can comment on or make changes to this bug.