Bug 200296 - Gossip crashes if I try to talk to anyone
Gossip crashes if I try to talk to anyone
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gossip (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 14:18 EDT by gareth foster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 11:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 348823 None None None Never

  None (edit)
Description gareth foster 2006-07-26 14:18:01 EDT
Description of problem:
Gossip crashes for me with 0.11.x on Fedora. Can we get Version 0.12 included in
extras? It may fix the problem.

Back trace follows ...

Backtrace was generated from '/usr/bin/gossip'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208862400 (LWP 8772)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x45e7d402 in __kernel_vsyscall ()
#0  0x45e7d402 in __kernel_vsyscall ()
#1  0x46a56be3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x4a562e26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x080956cd in gossip_theme_manager_apply ()
#5  0x080702ac in gossip_chat_view_append_message_from_self ()
#6  0x475c96aa in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#7  0x475b1012 in g_object_set () from /usr/lib/libgobject-2.0.so.0
#8  0x475aee6a in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#9  0x475af93f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x475afaf0 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#11 0x0806ea4b in gossip_chat_view_new ()
#12 0x0806bbf1 in gossip_chat_get_name ()
#13 0x475c94e2 in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#14 0x475b1012 in g_object_set () from /usr/lib/libgobject-2.0.so.0
#15 0x475aee6a in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#16 0x475af93f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x475afaf0 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#18 0x0808e3c5 in gossip_private_chat_new ()
#19 0x0806d5c9 in gossip_chat_manager_get_chat ()
#20 0x0806d6af in gossip_chat_manager_show_chat ()
#21 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0x475bae3d in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#23 0x475bc347 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#25 0x08078eb9 in gossip_contact_list_set_show_offline ()
#26 0x4ae9deed in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
#27 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#28 0x475bae3d in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#29 0x475bc347 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#30 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#31 0x4af6b881 in gtk_tree_view_row_activated ()
   from /usr/lib/libgtk-x11-2.0.so.0
#32 0x4af7899b in gtk_tree_view_get_hadjustment ()
   from /usr/lib/libgtk-x11-2.0.so.0
#33 0x4ae9f58e in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
#34 0x475a87a9 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
#35 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#36 0x475bb483 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#37 0x475bc10f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#38 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#39 0x4af8a858 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#40 0x4ae98f63 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#41 0x4ae9a1b7 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#42 0x4a49585a in gdk_add_client_message_filter ()
   from /usr/lib/libgdk-x11-2.0.so.0
#43 0x46fa415d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#44 0x46fa73ef in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#45 0x46fa7799 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#46 0x4ae9a634 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#47 0x08086935 in main ()

Thread 1 (Thread -1208862400 (LWP 8772)):
#0  0x45e7d402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x46a56be3 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x4a562e26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x080956cd in gossip_theme_manager_apply ()
No symbol table info available.
#5  0x080702ac in gossip_chat_view_append_message_from_self ()
No symbol table info available.
#6  0x475c96aa in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#7  0x475b1012 in g_object_set () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#8  0x475aee6a in g_object_newv () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x475af93f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x475afaf0 in g_object_new () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x0806ea4b in gossip_chat_view_new ()
No symbol table info available.
#12 0x0806bbf1 in gossip_chat_get_name ()
No symbol table info available.
#13 0x475c94e2 in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x475b1012 in g_object_set () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#15 0x475aee6a in g_object_newv () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#16 0x475af93f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#17 0x475afaf0 in g_object_new () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#18 0x0808e3c5 in gossip_private_chat_new ()
No symbol table info available.
#19 0x0806d5c9 in gossip_chat_manager_get_chat ()
No symbol table info available.
#20 0x0806d6af in gossip_chat_manager_show_chat ()
No symbol table info available.
#21 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#22 0x475bae3d in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#23 0x475bc347 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#24 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#25 0x08078eb9 in gossip_contact_list_set_show_offline ()
No symbol table info available.
#26 0x4ae9deed in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#27 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#28 0x475bae3d in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#29 0x475bc347 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#30 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#31 0x4af6b881 in gtk_tree_view_row_activated ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#32 0x4af7899b in gtk_tree_view_get_hadjustment ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#33 0x4ae9f58e in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#34 0x475a87a9 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#35 0x475a9f8b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#36 0x475bb483 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#37 0x475bc10f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#38 0x475bc509 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#39 0x4af8a858 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#40 0x4ae98f63 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#41 0x4ae9a1b7 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#42 0x4a49585a in gdk_add_client_message_filter ()
   from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#43 0x46fa415d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#44 0x46fa73ef in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#45 0x46fa7799 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#46 0x4ae9a634 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#47 0x08086935 in main ()
No symbol table info available.
Comment 1 Brian Pepple 2006-07-26 16:10:02 EDT
0.12 is already built, and just waiting for the next signing/push.
Comment 2 gareth foster 2006-07-26 16:17:04 EDT
NB: 0.12 may not fix that crash, I haven't managed to build from source to try.
Comment 3 Brian Pepple 2006-07-31 10:43:58 EDT
Is Gossip still crashing with the update to 0.12?
Comment 4 gareth foster 2006-07-31 11:01:11 EDT
see associated gnome bugzilla entry,

problem strangely went away on 0.11 when i did

rpm -e gossip
yum install gossip

its like being back on windows  :)
Comment 5 Brian Pepple 2006-07-31 11:09:14 EDT
Hmm, very odd.  I was unable to reproduce this, and like Richard stated your
backtrace looks to be incomplete.  Regardless, it looks like this isn't a
problem any longer.

Note You need to log in before you can comment on or make changes to this bug.