Bug 200298 - nfs mount causes oops when portmapper not running
nfs mount causes oops when portmapper not running
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 14:26 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 17:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch (911 bytes, patch)
2006-08-01 16:37 EDT, Steve Dickson
no flags Details | Diff

  None (edit)
Description Doug Chapman 2006-07-26 14:26:36 EDT
Description of problem:

If portmap is not running an nfs mount will fail and cause a kernel oops.

This was originally tripped over when doing an nfs mount during a kickstart
install.  Turns out the reason is due to portmap not running at that point.  I
can reproduce this on an installed system if I kill port map then try an nfs mount.

If I do a "mount -o nolock" instead (with portmap not running) the mount is
successful.



[root@hpcp1 ~]# mount 10.12.11.1:/export /mnt
FS-Cache: Loaded
FS-Cache: netfs 'nfs' registered for caching
portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
lockd_up: makesock failed, error=-5
portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
mount[2165]: NaT consumption 17179869216 [1]
Modules linked in: nfs lockd fscache nfs_acl autofs4 hidp rfcomm l2cap bluetooth
sunrpc ipv6 vfat fat button parport_pc lp parport ide_cd cdrom sg ehci_hcd
ohci_hcd e1000 dm_snapshot dm_zero dm_mirror dm_mod ext3 jbd mptspi
scsi_transport_spi mptscsih mptbase qla2xxx scsi_transport_fc sd_mod scsi_mod

Pid: 2165, CPU 0, comm:                mount
psr : 00001010085a6010 ifs : 8000000000000286 ip  : [<a00000010026b130>]    Not
tainted
ip is at _atomic_dec_and_lock+0x10/0x120
unat: 0000000000000000 pfs : 0000000000000207 rsc : 0000000000000003
rnat: 0000000510ee271a bsps: e0000040754ed841 pr  : 02a000101a565569
ldrs: 0000000000000000 ccv : 0000000000000000 fpsr: 0009804c8a70033f
csd : 0000000000000000 ssd : 0000000000000000
b0  : a0000002016ba590 b6  : a0000001002121e0 b7  : a0000001004bd640
f6  : 1003e6b6b6b6b6b6b6b6b f7  : 1003e0000000000000418
f8  : 1003e0000000000000000 f9  : 100098300000000000000
f10 : 1003e000000000000001e f11 : 1003e0000000000000200
r1  : a000000100b5e3c0 r2  : a00000020124638c r3  : a000000201763f58
r8  : e000004074ef8000 r9  : fffffffffffff000 r10 : e00000407533e448
r11 : a000000100964b68 r12 : e000004074effa80 r13 : e000004074ef8000
r14 : 0000000000000000 r15 : 0000000000000000 r16 : ffffffffdead4ead
r17 : 00000000dead4ead r18 : a000000201740e74 r19 : a000000100964b38
r20 : 0000000040749600 r21 : a0007fffbf800000 r22 : 000000000101d258
r23 : 0000000000000002 r24 : e000004074960580 r25 : 0000000000052c00
r26 : e00000407fd56c90 r27 : 0000000000000000 r28 : a000000201740e78
r29 : 0000000000000000 r30 : a000000201740e80 r31 : e000004074ef9024

Call Trace:
 [<a000000100013da0>] show_stack+0x40/0xa0
                                sp=e000004074eff4a0 bsp=e000004074ef9480
 [<a0000001000146a0>] show_regs+0x840/0x880
                                sp=e000004074eff670 bsp=e000004074ef9428
 [<a0000001000335c0>] die+0x1c0/0x2c0
                                sp=e000004074eff670 bsp=e000004074ef93d8
 [<a000000100033710>] die_if_kernel+0x50/0x80
                                sp=e000004074eff690 bsp=e000004074ef93a8
 [<a0000001005d9d30>] ia64_fault+0x10f0/0x1200
                                sp=e000004074eff690 bsp=e000004074ef9350
 [<a00000010000c6e0>] ia64_leave_kernel+0x0/0x280
                                sp=e000004074eff8b0 bsp=e000004074ef9350
 [<a00000010026b130>] _atomic_dec_and_lock+0x10/0x120
                                sp=e000004074effa80 bsp=e000004074ef9320
 [<a0000002016ba590>] nfs_put_client+0x90/0x180 [nfs]
                                sp=e000004074effa80 bsp=e000004074ef9300
 [<a0000002016ba800>] nfs_free_server+0x180/0x260 [nfs]
                                sp=e000004074effa80 bsp=e000004074ef92d8
 [<a0000002016bc780>] nfs_create_server+0xce0/0xd20 [nfs]
                                sp=e000004074effa80 bsp=e000004074ef9288
 [<a0000002016cee20>] nfs_get_sb+0x9e0/0xa40 [nfs]
                                sp=e000004074effb50 bsp=e000004074ef9238
 [<a00000010014a4a0>] vfs_kern_mount+0x160/0x2e0
                                sp=e000004074effbe0 bsp=e000004074ef91e0
 [<a00000010014a6e0>] do_kern_mount+0x60/0xa0
                                sp=e000004074effbe0 bsp=e000004074ef91a0
 [<a000000100180d20>] do_mount+0xda0/0xea0
                                sp=e000004074effbe0 bsp=e000004074ef9138
 [<a000000100180f10>] sys_mount+0xf0/0x1a0
                                sp=e000004074effe10 bsp=e000004074ef90a8
 [<a00000010000c560>] ia64_ret_from_syscall+0x0/0x20
                                sp=e000004074effe30 bsp=e000004074ef90a8
 [<a000000000010620>] __start_ivt_text+0xffffffff00010620/0x400
                                sp=e000004074f00000 bsp=e000004074ef90a8
 Segmentation fault


Version-Release number of selected component (if applicable):
2.6.17-1.2449.fc6


How reproducible:
100%

Steps to Reproduce:
1. kill portmap
2. mount <server>:<dir> /mnt
3. wait for it to timeout talking to portmap then it oopses
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Dickson 2006-08-01 16:37:57 EDT
Created attachment 133439 [details]
Proposed Patch

Here is a proposed patch that seems to fix the problem.
I'll run it by the NFS maintainer to his thoughts on it...
Comment 2 Steve Dickson 2007-03-09 09:20:46 EST
This seems to be fixed in later kernels... there is what 
I see now...

portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
lockd_up: makesock failed, error=-5
portmap: server localhost not responding, timed out
RPC: failed to contact portmap (errno -5).
mount.nfs: Input/output error
Comment 3 Doug Chapman 2007-09-18 15:39:27 EDT
Steve,

This BZ is listed as needinfo from me but I don't see any questions.  I am no
longer seeing the issue so I am happy with closing it if you are.

- Doug

Note You need to log in before you can comment on or make changes to this bug.