Bug 200347 - (load-synaptics) X configuration is missing mouse section
X configuration is missing mouse section
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Mike McLean
:
: 201909 202342 203021 203305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 21:23 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 11:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.org config file (written by anaconda) (1.67 KB, text/plain)
2006-07-27 15:57 EDT, Bill Nottingham
no flags Details
X.org log file (40.97 KB, text/plain)
2006-07-27 15:58 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2006-07-26 21:23:40 EDT
IBM T40p laptop. Has both stick mouse and touchpad.

anaconda-written X config only had a Synaptics section - no mouse section. So
the stick mouse didn't work.

rawhide-20060726
Comment 1 Jeremy Katz 2006-07-26 21:45:05 EDT
Per ajax, this should work.  If not, it's an X server bug.
Comment 2 Adam Jackson 2006-07-27 15:44:06 EDT
notting, can you attach your X log and config?
Comment 3 Bill Nottingham 2006-07-27 15:57:23 EDT
Created attachment 133194 [details]
X.org config file (written by anaconda)
Comment 4 Bill Nottingham 2006-07-27 15:58:49 EDT
Created attachment 133195 [details]
X.org log file
Comment 5 Bill Nottingham 2006-07-27 15:59:56 EDT
Erm, assume Load "synaptics" isn't commented out. It behaves the same regardless.
Comment 6 Adam Jackson 2006-08-10 13:50:19 EDT
*** Bug 201909 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2006-08-11 10:53:46 EDT
Fixed in xorg-x11-server-1.1.1-20, verified on my thinkpad.  Now, if parsing the
log file reveals no instances of the mouse driver or of the void driver, the
server synthesizes a mouse device section.
Comment 8 Will Woods 2006-08-14 12:14:47 EDT
*** Bug 202342 has been marked as a duplicate of this bug. ***
Comment 9 Mephisto 2006-08-17 16:51:22 EDT
I pulled in 1.1.1-21 today after a 2 week holiday and i've been running xorg
without a mouse section in xorg.conf for a while, to allow auto-detection. As of
-21 (or probably -20, as read in post #7), it creates 2 devices, so the mouse
moves twice as fast. It used to create only 1, so it worked fine before.
Here's the relevant section of the log:

(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "AlwaysCore"
(**) <default pointer>: always reports core events
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
Comment 10 Adam Jackson 2006-08-18 11:13:52 EDT
*** Bug 203021 has been marked as a duplicate of this bug. ***
Comment 11 Adam Jackson 2006-08-21 14:01:44 EDT
*** Bug 203305 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.