Bug 200373 - Up2date tries to install already installed package (seamonkey)
Up2date tries to install already installed package (seamonkey)
Status: CLOSED DUPLICATE of bug 204389
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: seamonkey (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 04:54 EDT by Trond H. Amundsen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 10:41:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond H. Amundsen 2006-07-27 04:54:23 EDT
Description of problem:

Running up2date on an RHEL3 x86_64 system with seamonkey installed gives this
result:

# up2date -u

Fetching Obsoletes list for channel: rhel-x86_64-ws-3...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
seamonkey-nspr                          1.0.2          0.1.0.EL3         x86_64
seamonkey-nss                           1.0.2          0.1.0.EL3         x86_64


Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package seamonkey-nspr-1.0.2-0.1.0.EL3 is already installed
package seamonkey-nss-1.0.2-0.1.0.EL3 is already installed


Up2date is correct in that those packages are installed:

# rpm -q --qf '%{name}-%{version}-%{release} %{arch}\n' \
# seamonkey-nspr seamonkey-nss
seamonkey-nspr-1.0.2-0.1.0.EL3 x86_64
seamonkey-nss-1.0.2-0.1.0.EL3 x86_64


Version-Release number of selected component (if applicable):
up2date-4.4.69-20

How reproducible:
Always.

Steps to Reproduce:
1. Run up2date on an RHEL3u8 x86_64 system with the seamonkey rpms installed
  
Actual results:
Tries to install already installed packages seamonkey-{nspr,nss}

Expected results:
No available updates at this time :)

Additional info:
As far as I can see, this only affects x86_64 systems. We only have i386 and
x86_64 based systems, so I don't know about ia64 etc. I'm not really sure if
the problem is up2date, the seamonkey packages, rpm or something else.
Comment 1 Trond H. Amundsen 2006-07-31 04:29:43 EDT
Confirmed that this also happens with recent seamonkey packages, i.e.
seamonkey-nspr-1.0.3-0.el3.1 and seamonkey-nss-1.0.3-0.el3.1
Comment 2 Trond H. Amundsen 2006-08-01 03:47:24 EDT
Aha! Problem solved. The seamonkey packages replace the mozilla
packages:

  # rpm -q --obsoletes seamonkey-{nss,nspr}
  mozilla-nss  
  mozilla-nspr  

The bug is probably with the seamonkey packages, as they fail to
remove/replace the i386 version of mozilla on an x86_64 platform:

  # rpm -qa --qf '%{name} %{arch}\n' | grep mozilla
  mozilla-nss i386
  mozilla-nspr i386

  # rpm -qa --qf '%{name} %{arch}\n' | grep seamonkey
  seamonkey-nss x86_64
  seamonkey-mail x86_64
  seamonkey-nspr x86_64
  seamonkey x86_64

Remove the left-behind mozilla packages and the problem goes away:

  # rpm -e mozilla-nss mozilla-nspr

Voila! up2date works again.

  
Comment 3 Trond H. Amundsen 2006-08-07 11:34:24 EDT
I've changed component to 'seamonkey'. Although for me this bug is
solved, since there exists a nice workaround, I'll leave the bug
open. It's still a bug that should be fixed, IMHO. Feel free to close
it if you disagree.
Comment 4 Anders Haugerud 2006-08-24 03:05:58 EDT
Thaks Trond !!
The solution worked for me also.
Comment 5 Martin Stransky 2007-01-18 10:41:48 EST

*** This bug has been marked as a duplicate of 204389 ***

Note You need to log in before you can comment on or make changes to this bug.